summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-08-21 14:29:24 +0200
committerGordian Edenhofer2016-08-21 14:29:24 +0200
commite4d3da17719282375d5830b84fdab464c6cf9c68 (patch)
tree839db720cf2b8ed8639be9acbb296b93bb8acd81
parent4eaee9363571cb4f97f83999b36dcd5197c94565 (diff)
downloadaur-e4d3da17719282375d5830b84fdab464c6cf9c68.tar.gz
upgpkg: python-acme-git 0.8.1.r25.gaa4a263-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 4 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e596b99d21c2..4f66939df395 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,6 +43,7 @@ pkgname = python-acme-git
depends = python-six
depends = python-werkzeug
depends = python-mock
+ optdepends = python-dnspython: local validation of dns-01 challenges
provides = python-acme=0.8.1.r25.gaa4a263
conflicts = python-acme
@@ -58,5 +59,6 @@ pkgname = python2-acme-git
depends = python2-six
depends = python2-werkzeug
depends = python2-mock
+ optdepends = python2-dnspython: local validation of dns-01 challenges
provides = python2-acme=0.8.1.r25.gaa4a263
conflicts = python2-acme
diff --git a/PKGBUILD b/PKGBUILD
index 63fd6ef1d07e..a3f47e225a4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,6 +51,7 @@ package_python-acme-git() {
depends=('python-setuptools' 'python-pyasn1' 'python-cryptography' 'python-pyopenssl'
'python-ndg-httpsclient' 'python-pyrfc3339' 'python-pytz' 'python-requests'
'python-six' 'python-werkzeug' 'python-mock')
+ optdepends=("python-dnspython: local validation of dns-01 challenges")
provides=("python-acme=${pkgver}")
conflicts=("python-acme")
@@ -62,6 +63,7 @@ package_python2-acme-git() {
depends=('python2-setuptools' 'python2-pyasn1' 'python2-cryptography' 'python2-pyopenssl'
'python2-ndg-httpsclient' 'python2-pyrfc3339' 'python2-pytz' 'python2-requests'
'python2-six' 'python2-werkzeug' 'python2-mock')
+ optdepends=("python2-dnspython: local validation of dns-01 challenges")
provides=("python2-acme=${pkgver}")
conflicts=("python2-acme")