summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-12-16 21:42:33 +0800
committerUniversebenzene2020-12-16 21:42:33 +0800
commit416a7478645d0915f50bb48b7356fe665cc0feae (patch)
treebd12ed159c80c3ec6b3bef56c3a185eb8c63bdc9
parent14c0be6e7adc8d47b29750eba4325ae8d342e4c4 (diff)
downloadaur-python-acstools.tar.gz
Update to version 3.3.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d6d6f48bf9..4de5e7f4d15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-acstools
pkgdesc = Python Tools for ACS (Advanced Camera for Surveys) Data
- pkgver = 3.2.0
+ pkgver = 3.3.1
pkgrel = 1
url = https://acstools.readthedocs.io/
arch = i686
@@ -11,10 +11,12 @@ pkgbase = python-acstools
checkdepends = python-beautifulsoup4
checkdepends = python-requests
checkdepends = python-ci_watson
+ checkdepends = python-yaml
+ checkdepends = python-matplotlib
makedepends = python-setuptools-scm
- source = https://files.pythonhosted.org/packages/source/a/acstools/acstools-3.2.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/a/acstools/acstools-3.3.1.tar.gz
source = https://raw.githubusercontent.com/spacetelescope/acstools/master/LICENSE.md
- md5sums = cf89f3ee47047acca7c563bbacc6503b
+ md5sums = 70a60fb2076ea289cf898634c82a14c0
md5sums = SKIP
pkgname = python-acstools
@@ -22,6 +24,7 @@ pkgname = python-acstools
depends = python-astropy>=3.1
depends = python-beautifulsoup4
depends = python-requests
+ depends = python-yaml
optdepends = python-matplotlib
optdepends = python-scipy
optdepends = python-scikit-image
diff --git a/PKGBUILD b/PKGBUILD
index a12db3f58d9..2b6f0fc59a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-acstools
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=3.2.0
+pkgver=3.3.1
pkgrel=1
pkgdesc="Python Tools for ACS (Advanced Camera for Surveys) Data"
arch=('i686' 'x86_64')
@@ -15,10 +15,12 @@ checkdepends=('python-pytest-astropy-header'
'python-astropy'
'python-beautifulsoup4'
'python-requests'
- 'python-ci_watson')
+ 'python-ci_watson'
+ 'python-yaml'
+ 'python-matplotlib')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/spacetelescope/acstools/master/LICENSE.md")
-md5sums=('cf89f3ee47047acca7c563bbacc6503b'
+md5sums=('70a60fb2076ea289cf898634c82a14c0'
'SKIP')
build() {
@@ -37,7 +39,7 @@ check() {
}
package() {
- depends=('python>=3.6' 'python-astropy>=3.1' 'python-beautifulsoup4' 'python-requests')
+ depends=('python>=3.6' 'python-astropy>=3.1' 'python-beautifulsoup4' 'python-requests' 'python-yaml')
optdepends=('python-matplotlib'
'python-scipy'
'python-scikit-image'