summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2021-08-25 08:54:08 +0200
committerrazer2021-08-25 08:54:08 +0200
commit3a57e4792634dcc0ddc6cc2ceef2ca0b8ff1c3e7 (patch)
treefdeda8bc06df9cea4b978871f3374df14a1b84dd
downloadaur-3a57e4792634dcc0ddc6cc2ceef2ca0b8ff1c3e7.tar.gz
Initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75fb521a46dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-adafruit-circuitpython-bme280
+ pkgdesc = CircuitPython library for the Bosch BME280 temperature/humidity/pressure sensor
+ pkgver = 2.6.6
+ pkgrel = 0
+ url = https://github.com/adafruit/Adafruit_CircuitPython_BME280
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python
+ depends = python-adafruit-circuitpython-busdevice
+ optdepends = python-raspberry-gpio
+ source = https://pypi.io/packages/source/a/adafruit-circuitpython-bme280/adafruit-circuitpython-bme280-2.6.6.tar.gz
+ sha256sums = 67e484756fb8725efec903cbc9fc3d1748dd205b25c6598df8bd69faa234aa3f
+
+pkgname = python-adafruit-circuitpython-bme280
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad25e1e6a52a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Razer <razer[AT]neuf[DOT]fr>
+
+pkgname=python-adafruit-circuitpython-bme280
+_pypi_pkgname=adafruit-circuitpython-bme280
+pkgver=2.6.6
+pkgrel=0
+pkgdesc="CircuitPython library for the Bosch BME280 temperature/humidity/pressure sensor"
+arch=('armv6h' 'armv7h' 'aarch64')
+url="https://github.com/adafruit/Adafruit_CircuitPython_BME280"
+license=('MIT')
+makedepends=('python-setuptools' 'python-pip')
+depends=('python' 'python-adafruit-circuitpython-busdevice')
+optdepends=('python-raspberry-gpio')
+source=("https://pypi.io/packages/source/a/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
+sha256sums=('67e484756fb8725efec903cbc9fc3d1748dd205b25c6598df8bd69faa234aa3f')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}