summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSiôn le Roux2021-02-21 22:47:22 +0100
committerSiôn le Roux2021-02-21 22:57:57 +0100
commit94721befd21f0f46eb7a54cc53bd34a781dc2aa5 (patch)
treed8dd00a60783941b4f5a4dc9a58b3715c38fabc1
parent5c6aa1acab9c000ab7b194e2b250f692012d7911 (diff)
downloadaur-94721befd21f0f46eb7a54cc53bd34a781dc2aa5.tar.gz
Move Raspberry Pi GPIO to optional dependencies
Since I'm already here I'm adding the other two optional dependencies mentioned in the AUR comments.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 669740e9c21f..fd790d9160bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,10 @@ pkgbase = python-adafruit-gpio-git
license = MIT
makedepends = git
depends = python
- depends = python-raspberry-gpio
depends = python-smbus
+ optdepends = python-raspberry-gpio: for Raspberry Pi support
+ optdepends = python-adafruit_bbio-git: for BeagleBone support
+ optdepends = libftdi: for FT232H support
provides = python-adafruit-gpio
conflicts = python-adafruit-gpio
source = python-adafruit-gpio::git+https://github.com/adafruit/Adafruit_Python_GPIO.git
diff --git a/PKGBUILD b/PKGBUILD
index c2b58e364ac6..75b846ee3ea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,11 @@ arch=('any')
url="https://github.com/adafruit/Adafruit_Python_GPIO"
license=('MIT')
groups=()
-depends=('python' 'python-raspberry-gpio' 'python-smbus')
+depends=('python' 'python-smbus')
+optdepends=(
+ 'python-raspberry-gpio: for Raspberry Pi support'
+ 'python-adafruit_bbio-git: for BeagleBone support'
+ 'libftdi: for FT232H support')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")