summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2015-10-04 09:23:06 +0200
committerrazer2015-10-04 09:23:06 +0200
commit3b31aca024ac1019299bedd7d7091b601469e7b1 (patch)
treec7b0325bee37f6c138c21db0047ae4f08c37d8eb
downloadaur-3b31aca024ac1019299bedd7d7091b601469e7b1.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..575e5260b96d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-adafruit_dht
+ pkgdesc = Python library to read the DHT series of humidity and temperature sensors on a Raspberry Pi or Beaglebone Black.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/mala-zaba/Adafruit_Python_DHT
+ arch = armv5h
+ arch = armv7h
+ license = GPLv3
+ depends = python
+ depends = git
+ source = git://github.com/mala-zaba/Adafruit_Python_DHT
+ md5sums = SKIP
+
+pkgname = python-adafruit_dht
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..548a166c1fee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: razer <razer[at]neuf[dot]fr>
+pkgname=python-adafruit_dht
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Python library to read the DHT series of humidity and temperature sensors on a Raspberry Pi or Beaglebone Black."
+url="https://github.com/mala-zaba/Adafruit_Python_DHT"
+arch=('armv5h' 'armv7h')
+license=('GPLv3')
+depends=('python' 'git')
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=()
+source=("git://github.com/mala-zaba/Adafruit_Python_DHT")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/Adafruit_Python_DHT"
+ if [ "$(grep AM33 /proc/cpuinfo)" = "" ]; then
+ python setup.py install --force-bbb --root="$pkgdir/" --optimize=1
+ else
+ python setup.py install --force-pi --root="$pkgdir/" --optimize=1
+ fi
+}
+
+# vim:set ts=2 sw=2 et: