summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2016-10-22 11:28:28 +0200
committerrazer2016-10-22 11:28:28 +0200
commit8b42269bf766337fe8358151a7d065f095c16f3d (patch)
treecc04df5163eb3543632a2f016f384a82cd9d9f4e
downloadaur-8b42269bf766337fe8358151a7d065f095c16f3d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2306f678414f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-adafruit_nokia_lcd
+ pkgdesc = Python library for the using the Nokia 5110/3310 monochrome graphic LCD with a Raspberry Pi or Beaglebone Black
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/adafruit/Adafruit_Nokia_LCD
+ arch = armv6h
+ arch = armv7h
+ arch = x86
+ arch = x86_64
+ license = MIT
+ depends = python
+ source = git://github.com/adafruit/Adafruit_Nokia_LCD
+ md5sums = SKIP
+
+pkgname = python-adafruit_nokia_lcd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a140eda2ddc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: razer <razer[at]neuf[dot]fr>
+pkgname=python-adafruit_nokia_lcd
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Python library for the using the Nokia 5110/3310 monochrome graphic LCD with a Raspberry Pi or Beaglebone Black'
+url='https://github.com/adafruit/Adafruit_Nokia_LCD'
+arch=('armv6h' 'armv7h' 'x86' 'x86_64')
+license=('MIT')
+depends=('python')
+source=("git://github.com/adafruit/Adafruit_Nokia_LCD")
+md5sums=('SKIP')
+
+package() {
+ cd Adafruit_Nokia_LCD
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}