summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2018-03-08 19:38:50 +0100
committerMatteo De Carlo2018-03-08 19:38:50 +0100
commit191484245a3f2a1e2faeb695867d67a143495129 (patch)
tree07a4718164f21ee4d98ed5ef9ccf29efdbe4ddec
parent3ff976d2c748af22277ec4997c0dbc9dccf9d812 (diff)
downloadaur-191484245a3f2a1e2faeb695867d67a143495129.tar.gz
Added patch for dependencies version
we don't want hardcoded dependencies, plese be flexible
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2b5f7fb21a9..5484629e389e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,30 @@ source=("https://pypi.python.org/packages/36/a4/3ef82c754a8fb079a98d0adb66be1e3d
sha256sums=('9445c9be4fcf3c519d1fbc605ea289349e11c2eb581db72242b61d12cc4d337f')
+prepare() {
+ cd $srcdir/${_pkgsrcname}-$pkgver
+ echo '
+--- a/setup.py 2018-03-08 19:10:47.272990956 +0100
++++ b/setup.py 2018-03-08 19:11:09.107832840 +0100
+@@ -14,7 +14,7 @@ setup(
+ packages = ["adapt", "adapt.tools", "adapt.tools.text"],
+
+ install_requires = [
+- "pyee==1.0.1",
+- "six==1.10.0"
++ "pyee>=1.0.1",
++ "six>=1.10.0"
+ ]
+ )
+' | patch -p1
+
+}
+
+build() {
+ cd $srcdir/${_pkgsrcname}-$pkgver
+ python3 setup.py build
+}
+
package() {
cd $srcdir/${_pkgsrcname}-$pkgver
python3 setup.py install --root $pkgdir