summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiklas2018-08-20 00:23:17 +0200
committerNiklas2018-08-20 00:23:17 +0200
commit4d6b1b3c122cf45017b69cadbf5af715790ae82e (patch)
treee561c3dd86d98e1a67139a142739ebc6178132aa
parent507751cdc5b58809fff5d54a506f8cc19f91a3e1 (diff)
downloadaur-4d6b1b3c122cf45017b69cadbf5af715790ae82e.tar.gz
[1.3.0-1] update
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c93aceeb6d9..48f9f37c11d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-adb
pkgdesc = A pure Python implementation of the Android ADB and Fastboot protocols
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://github.com/google/python-adb
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/a/adb/adb-1.2.0.tar.gz
- sha512sums = 2bb02adbd43602471a48f8de92fd660835b9f0dfc41df30ebdbf6408f410ff56fc7e073b0e636ac1f1ed44aa98719e10ed64f646f5e5477d321a676c7f2f1708
+ source = https://files.pythonhosted.org/packages/source/a/adb/adb-1.3.0.tar.gz
+ sha512sums = 0ec5c2acee688498c065cfd136491594631e5410121f9f856cf9d0818af238bbf41f2646bf50b8503873bbd48e9bc97065638d3f4af35ba82681a0c84a26139c
pkgname = python-adb
depends = python-libusb1
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..19b7361f8252
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.log
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index aa86f56ee984..159e82fce57b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
pkgbase=python-adb
pkgname=(python-adb python2-adb)
_name=adb
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.3.0
+pkgrel=1
pkgdesc="A pure Python implementation of the Android ADB and Fastboot protocols"
arch=('any')
url="https://github.com/google/python-adb"
license=('Apache')
makedepends=('python-setuptools' 'python2-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('2bb02adbd43602471a48f8de92fd660835b9f0dfc41df30ebdbf6408f410ff56fc7e073b0e636ac1f1ed44aa98719e10ed64f646f5e5477d321a676c7f2f1708')
+sha512sums=('0ec5c2acee688498c065cfd136491594631e5410121f9f856cf9d0818af238bbf41f2646bf50b8503873bbd48e9bc97065638d3f4af35ba82681a0c84a26139c')
prepare() {
cd "${srcdir}"
- cp -a ${_name}-${pkgver}{,-python2}
+ cp -a ${_name}-${pkgver}{,-python2}
find "${_name}-${pkgver}-python2" -name \*.py -exec sed -r 's|^#!(.*)python$|#!\1python2|' -i {} +
}