summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranck Lucien Duriez2018-08-10 12:02:23 +0200
committerFranck Lucien Duriez2018-08-10 12:03:13 +0200
commit14913e63019cd8acff0c83e4e045f7057f417a92 (patch)
tree424340c6cc44ca44b305cea414dab05dbf705027
downloadaur-14913e63019cd8acff0c83e4e045f7057f417a92.tar.gz
First commit.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8965d50f1f6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-adb-enhanced
+ pkgdesc = Swiss-army knife for Android testing and development.
+ pkgver = 1.8
+ pkgrel = 6
+ url = https://github.com/ashishb/adb-enhanced
+ arch = any
+ license = Apache License 2.0
+ depends = python
+ depends = android-tools
+ source = https://github.com/ashishb/adb-enhanced/archive/1.8.6.tar.gz
+ sha256sums = 1810695daab59a28e72d3a87eaec7b1a5a83a294d0194cdeda7557a291eab42a
+
+pkgname = python-adb-enhanced
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adb93abe90d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Franck Lucien Duriez <franck.lucien.duriez@gmail.com>
+_pyname="adb-enhanced"
+pkgname="python-${_pyname}"
+pkgver=1.8
+pkgrel=6
+pkgdesc="Swiss-army knife for Android testing and development."
+arch=("any")
+url=""
+license=("Apache License 2.0")
+depends=("python" "android-tools")
+url="https://github.com/ashishb/adb-enhanced"
+source=("https://github.com/ashishb/${_pyname}/archive/${pkgver}.${pkgrel}.tar.gz")
+sha256sums=("1810695daab59a28e72d3a87eaec7b1a5a83a294d0194cdeda7557a291eab42a")
+
+build() {
+ cd "${srcdir}/${_pyname}-${pkgver}.${pkgrel}/${_pyname}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}.${pkgrel}/${_pyname}"
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}