summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2020-10-18 01:56:00 +0200
committerKokaKiwi2020-10-18 01:56:00 +0200
commit4e7778f0fe208e79f484cf1e074024f6c4dc62ab (patch)
tree4a117932a5fa71a7338d3888932fd4884929e183
downloadaur-4e7778f0fe208e79f484cf1e074024f6c4dc62ab.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..474832cfa316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-adb_shell
+ pkgdesc = A Python implementation of ADB with shell and FileSync functionality.
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://pypi.org/project/adb_shell
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-aiofiles: async API
+ optdepends = python-libusb1: To connect to a device via USB
+ source = python-adb_shell-0.2.3.tar.gz::https://pypi.python.org/packages/source/a/adb_shell/adb_shell-0.2.3.tar.gz
+ sha256sums = 91fd0684564742728864f653045db44acc19db474483a3f4e0c4e0a2a1c7d7f4
+ b2sums = 1e47a0d666bbfe1a8b56b1a5977338a382a427400a60e62c3983d7a1c96d1bc66a3df9e242627d2912cb52442ac90bf28e6856f9b31ef6484b3014abe2c7b241
+
+pkgname = python-adb_shell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee9af29367a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+_pkgname=adb_shell
+pkgname="python-${_pkgname}"
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="A Python implementation of ADB with shell and FileSync functionality."
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('python-aiofiles: async API'
+ 'python-libusb1: To connect to a device via USB')
+source=("${pkgname}-${pkgver}.tar.gz::https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname/-/_}/${_pkgname/-/_}-${pkgver}.tar.gz")
+sha256sums=('91fd0684564742728864f653045db44acc19db474483a3f4e0c4e0a2a1c7d7f4')
+b2sums=('1e47a0d666bbfe1a8b56b1a5977338a382a427400a60e62c3983d7a1c96d1bc66a3df9e242627d2912cb52442ac90bf28e6856f9b31ef6484b3014abe2c7b241')
+
+build() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ python setup.py build
+}
+
+check() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ export PYTHONPATH="build/lib"
+ python setup.py test
+}
+
+package() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}