summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2020-10-18 02:15:10 +0200
committerKokaKiwi2020-10-18 02:15:10 +0200
commita5e421132afbef2d19795d71d2cba24db9a180b3 (patch)
tree6d59e03c043140d007374da62c6a0c657295a177
parent4e7778f0fe208e79f484cf1e074024f6c4dc62ab (diff)
downloadaur-a5e421132afbef2d19795d71d2cba24db9a180b3.tar.gz
Add python packages dependencies (forgot them..)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 474832cfa316..fa44577759cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = python-adb_shell
pkgdesc = A Python implementation of ADB with shell and FileSync functionality.
pkgver = 0.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.org/project/adb_shell
arch = any
license = Apache
makedepends = python-setuptools
depends = python
+ depends = python-cryptography
+ depends = python-pyasn1
+ depends = python-rsa
optdepends = python-aiofiles: async API
optdepends = python-libusb1: To connect to a device via USB
source = python-adb_shell-0.2.3.tar.gz::https://pypi.python.org/packages/source/a/adb_shell/adb_shell-0.2.3.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index ee9af29367a7..49a417ac40f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=adb_shell
pkgname="python-${_pkgname}"
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Python implementation of ADB with shell and FileSync functionality."
arch=('any')
url="https://pypi.org/project/${_pkgname}"
license=('Apache')
-depends=('python')
+depends=('python' 'python-cryptography' 'python-pyasn1' 'python-rsa')
makedepends=('python-setuptools')
optdepends=('python-aiofiles: async API'
'python-libusb1: To connect to a device via USB')