summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2019-11-24 23:26:35 +0100
committerMikhail f. Shiryaev2019-11-24 23:26:35 +0100
commitefe86229d5d0fc7e07f1ff59d5c2e4a51f6faccb (patch)
treee179eafc8ec6d29dd302f32428f2844e295473f4
parent46340e70719db085d8d29b42a21b3296502f22ec (diff)
downloadaur-efe86229d5d0fc7e07f1ff59d5c2e4a51f6faccb.tar.gz
Remove one entrypoint, add package relations
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--adminapi-only.patch12
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddec455b603f..c05442b772e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-adminapi
pkgdesc = Adminapi is a python module which can be used to talk to the open source serveradmin project by Innogames
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/InnoGames/serveradmin
arch = any
license = MIT
@@ -9,11 +9,12 @@ pkgbase = python-adminapi
depends = python
depends = python-ipaddress
depends = python-netaddr
- conflicts = python-adminapi-git
+ provides = python-adminapi
+ conflicts = python-adminapi
source = serveradmin.tar.gz::https://github.com/InnoGames/serveradmin/archive/v1.7.0.tar.gz
source = adminapi-only.patch
sha256sums = aad9999e3b9ef37389025435c7dd20323b0420dc50786c247e731e18a13e08e2
- sha256sums = a1b19bafdfb32f997cfacb4855cfcbb1681e77fbff1ec292aa4cdbaebb11d107
+ sha256sums = 086a0f7a7b935b27e1ece35d99202b4db10f6b5a4406dd45affba2bfaf89a08e
pkgname = python-adminapi
diff --git a/PKGBUILD b/PKGBUILD
index 7350386a28d2..dbbd7f9fe58e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,14 @@ _srcname=serveradmin
pkgname="python-${_name}"
conflicts=("python-${_name}-git")
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Adminapi is a python module which can be used to talk to the open source serveradmin project by Innogames'
arch=('any')
url="https://github.com/InnoGames/${_srcname}"
makedepends=('python-setuptools')
depends=('python' 'python-ipaddress' 'python-netaddr')
+provides=('python-adminapi')
+conflicts=('python-adminapi')
license=('MIT')
source=(
"${_srcname}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
@@ -18,7 +20,7 @@ source=(
)
sha256sums=(
'aad9999e3b9ef37389025435c7dd20323b0420dc50786c247e731e18a13e08e2'
- 'a1b19bafdfb32f997cfacb4855cfcbb1681e77fbff1ec292aa4cdbaebb11d107'
+ '086a0f7a7b935b27e1ece35d99202b4db10f6b5a4406dd45affba2bfaf89a08e'
)
diff --git a/adminapi-only.patch b/adminapi-only.patch
index 60092b541af1..f82914e45600 100644
--- a/adminapi-only.patch
+++ b/adminapi-only.patch
@@ -1,5 +1,5 @@
---- src/serveradmin-1.7.0/setup.py 2019-08-07 15:43:13.000000000 +0200
-+++ for_patch 2019-11-24 22:27:56.427862010 +0100
+--- a/setup.py 2019-11-24 23:12:47.120782692 +0100
++++ b/setup.py 2019-11-24 23:14:51.695064193 +0100
@@ -14,7 +14,7 @@
name='adminapi',
description='Serveradmin module',
@@ -9,3 +9,11 @@
package_data={
'serveradmin.api': ['templates/api/*'],
'serveradmin.apps': ['templates/apps/*'],
+@@ -43,7 +43,6 @@
+ },
+ entry_points={
+ 'console_scripts': [
+- 'serveradmin=serveradmin.__main__:main',
+ 'adminapi=adminapi.__main__:main',
+ ],
+ },