summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2019-11-19 09:41:44 +0100
committerStefan Tatschner2019-11-19 09:41:44 +0100
commit56b65cead761d017cabc224530f2adc93fe4314b (patch)
tree815e6b4ef20cfac2df58fae1e2632f9171c46e9e
parent7143ef1e17ce8a2b3b31c46858eb069be892c446 (diff)
downloadaur-56b65cead761d017cabc224530f2adc93fe4314b.tar.gz
Update workaround for python3.8
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a0f7ccea975..73ac2caef08d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-aenum
pkgdesc = Advanced Enumerations (compatible with Python's stdlib Enum), NamedTuples, and NamedConstants
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/stoneleaf/aenum
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 6f3ade94933e..c993c58e9f7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('python-aenum' 'python2-aenum')
_pkgname='aenum'
pkgver=2.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Advanced Enumerations (compatible with Python's stdlib Enum), NamedTuples, and NamedConstants"
arch=('any')
url="https://bitbucket.org/stoneleaf/aenum"
@@ -26,7 +26,7 @@ package_python-aenum() {
python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
# XXX: I have no idea what's wrong with the setup.py. This is a quickfix!
- install -Dm644 aenum/__init__.py "${pkgdir}/usr/lib/python3.7/site-packages/${_pkgname}/__init__.py"
+ install -Dm644 aenum/__init__.py "${pkgdir}/usr/lib/python3.8/site-packages/${_pkgname}/__init__.py"
install -Dm644 aenum/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}