summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Pałubicki2019-03-16 21:15:56 +0100
committerMichał Pałubicki2019-03-16 21:18:14 +0100
commitc8dc771b1280c9ad953013d1cb4c7336d998c18b (patch)
tree1eaf08bd62ad43c58b3fc504db6eabd0b719b6b8
parent64e166f469cd58593d5ec598d67da18cbd5fa01f (diff)
downloadaur-c8dc771b1280c9ad953013d1cb4c7336d998c18b.tar.gz
Reduce package size by linking to rtd theme package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78c1c8959354..17086e302044 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,11 @@ pkgbase = python-agate-excel
license = MIT
makedepends = python-setuptools
makedepends = python-sphinx>=1.2.2
- makedepends = python-sphinx_rtd_theme>=0.1.6
depends = python
depends = python-agate>=1.5.0
depends = python-xlrd>=0.9.4
depends = python-openpyxl>=2.3.0
+ depends = python-sphinx_rtd_theme>=0.1.6
source = https://github.com/wireservice/agate-excel/archive/0.2.2.tar.gz
source = openpyxl-min_row.patch
sha256sums = 37acbc114c4c60aa37f908d93a9e9b597c3ba0ee42672f36f7a317f8af8fc581
diff --git a/PKGBUILD b/PKGBUILD
index dd8bfeb4c497..f32ff771a4bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,11 @@ depends=(
'python-agate>=1.5.0'
'python-xlrd>=0.9.4'
'python-openpyxl>=2.3.0'
+ 'python-sphinx_rtd_theme>=0.1.6'
)
makedepends=(
'python-setuptools'
'python-sphinx>=1.2.2'
- 'python-sphinx_rtd_theme>=0.1.6'
)
source=(
"https://github.com/wireservice/agate-excel/archive/${pkgver}.tar.gz"
@@ -42,6 +42,10 @@ package() {
python setup.py build_sphinx
mkdir -p "$pkgdir/usr/share/doc"
cp -rv "$srcdir/$_pkgname-$pkgver/build/sphinx/html" "$pkgdir/usr/share/doc/$_pkgname"
+
+ _rtd_theme_path="$(python -c 'import sphinx_rtd_theme; print(sphinx_rtd_theme.get_html_theme_path())')"
+ rm -rvf "$pkgdir/usr/share/doc/$_pkgname/_static"
+ ln -svf "$_rtd_theme_path/sphinx_rtd_theme/static" "$pkgdir/usr/share/doc/$_pkgname/_static"
}
check() {