summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2020-09-13 19:19:47 -0400
committerMiguel de Val-Borro2020-09-13 19:19:47 -0400
commita932ee24931d014d01d51f010a68cf34293ab7db (patch)
tree637bd07f4d6c3dc84c7d0977307f1041907b16aa
downloadaur-a932ee24931d014d01d51f010a68cf34293ab7db.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1d01e78b9dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-agnpy
+ pkgdesc = Modelling Active Galactic Nuclei radiative processes with python.
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://agnpy.readthedocs.io/
+ arch = x86_64
+ license = BSD
+ depends = python
+ depends = python-numpy
+ depends = python-astropy
+ depends = python-matplotlib
+ source = https://github.com/cosimoNigro/agnpy/archive/v0.0.7.tar.gz
+ md5sums = 6b6561a49e69e47ac1b942d666642cca
+
+pkgname = python-agnpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab416710c581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Miguel de Val-Borro <miguel dot deval at gmail dot com>
+
+pkgname=python-agnpy
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="Modelling Active Galactic Nuclei radiative processes with python."
+arch=('x86_64')
+url="https://agnpy.readthedocs.io/"
+license=('GPL')
+depends=('python'
+ 'python-numpy'
+ 'python-astropy'
+ 'python-matplotlib')
+source=("https://github.com/cosimoNigro/agnpy/archive/v${pkgver}.tar.gz")
+md5sums=('6b6561a49e69e47ac1b942d666642cca')
+
+package(){
+ cd $srcdir/agnpy-$pkgver
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}