summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrikilinux2021-12-16 19:20:28 -0300
committerFrikilinux2021-12-16 19:20:28 -0300
commitf4df307075e86c6f368e646e50e5ecdabdc997dd (patch)
tree74e942e5c752d54aed16085886a59b236be73247
parentea59696ba032125c8181eeb167252d38100b0bae (diff)
downloadaur-f4df307075e86c6f368e646e50e5ecdabdc997dd.tar.gz
Update to new version. Clean sources
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD17
3 files changed, 7 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c80f0a7759a..ff37aaca1695 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,10 @@ pkgbase = python-aigpy
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
depends = python-requests
depends = python-colorama
depends = python-mutagen
- source = https://pypi.org/packages/source/a/aigpy/aigpy-2021.9.10.3.tar.gz
- source = https://raw.githubusercontent.com/yaronzz/AIGPY/master/LICENSE
+ source = https://files.pythonhosted.org/packages/source/a/aigpy/aigpy-2021.9.10.3.tar.gz
sha256sums = 838aaaf62efb2a48847f07948cce0dc1a209828807545b914065b25c4e50c38d
- sha256sums = 83e4dd21429a91fb7cea67a476032a9641425e5355df2e0f589a738b6ec9fd2c
pkgname = python-aigpy
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index ab602974d200..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2018
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 3639444c0463..e159dfb6f3c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer : Frikilinux <frikilinux@gmail.com>
+# Contributor : peeweep <peeweep at 0x0 dot ee>
pkgname=python-aigpy
_pkgname=aigpy
@@ -9,28 +10,22 @@ arch=('any')
url="https://github.com/yaronzz/AIGPY"
license=('MIT')
depends=(
- 'python'
'python-requests'
'python-colorama'
'python-mutagen'
)
makedepends=('python-setuptools')
-source=(
- "https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/yaronzz/AIGPY/master/LICENSE")
-sha256sums=('838aaaf62efb2a48847f07948cce0dc1a209828807545b914065b25c4e50c38d'
- '83e4dd21429a91fb7cea67a476032a9641425e5355df2e0f589a738b6ec9fd2c')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+sha256sums=('838aaaf62efb2a48847f07948cce0dc1a209828807545b914065b25c4e50c38d')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
-
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: