summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Gee2018-12-01 05:34:34 -0800
committerJohn-Gee2018-12-01 05:34:34 -0800
commitac0f0ca64b59581c9384ba8c6a2072425ffb9482 (patch)
tree53f8fae7b08628cc8778787f9ed96150989baef3
downloadaur-ac0f0ca64b59581c9384ba8c6a2072425ffb9482.tar.gz
Creation of the package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c766803412b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-aiocache
+ pkgdesc = Asyncio cache manager for redis, memcached and memory
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/argaen/aiocache
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-aioredis
+ optdepends = python-ujson
+ source = https://github.com/argaen/aiocache/archive/0.10.1.tar.gz
+ md5sums = bfefdfe5cd80951578278b9b2a6eb944
+
+pkgname = python-aiocache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e607b697b50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: geearf
+
+pkgname=python-aiocache
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Asyncio cache manager for redis, memcached and memory"
+arch=(any)
+url="https://github.com/argaen/aiocache"
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python')
+optdepends=('python-aioredis' 'python-ujson')
+source=("https://github.com/argaen/aiocache/archive/${pkgver}.tar.gz")
+md5sums=('bfefdfe5cd80951578278b9b2a6eb944')
+
+build() {
+ cd "${srcdir}/aiocache-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/aiocache-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+}