summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm-pilia2017-10-31 15:49:27 +0100
committerm-pilia2017-10-31 15:49:27 +0100
commit258bef5f6de71d3e3c0e083d7c5a33e470ca46e3 (patch)
tree2a981869e741c232faf102d8e416bccc1d50a5bf
downloadaur-258bef5f6de71d3e3c0e083d7c5a33e470ca46e3.tar.gz
submission
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61e2be34a096
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-aiocoap-git
+ pkgdesc = Python implementation of CoAP
+ pkgver = 0.3.r320.g3286f48
+ pkgrel = 1
+ url = https://github.com/chrysn/aiocoap
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python>=3.4.4
+ provides = python-aiocoap
+ source = git+https://github.com/chrysn/aiocoap.git
+ sha512sums = SKIP
+
+pkgname = python-aiocoap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e01ce01e6bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=aiocoap
+pkgname=python-${_pkgname}-git
+pkgver=0.3.r320.g3286f48
+pkgrel=1
+pkgdesc="Python implementation of CoAP"
+arch=('any')
+url="https://github.com/chrysn/aiocoap"
+license=('MIT')
+provides=("python-${_pkgname}")
+depends=('python>=3.4.4')
+makedepends=('python-setuptools')
+source=("git+https://github.com/chrysn/aiocoap.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir"
+}