summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12020-01-29 18:32:16 +0500
committerevgfilim12020-01-29 18:33:21 +0500
commit5163c06e4465430f5ade189c572a6601b1a9abd6 (patch)
tree48c1b47fc60cf841faafb89d6c3e08c502683a62
parent4a4868e296b138aa10dd9242dd190e30ae12bb3d (diff)
downloadaur-5163c06e4465430f5ade189c572a6601b1a9abd6.tar.gz
New version: v2.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 14 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f04223825eb..ff9a9f0dd8be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-aiogram
pkgdesc = A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp
- pkgver = 2.6
+ pkgver = 2.6.1
pkgrel = 1
url = https://github.com/aiogram/aiogram
arch = any
@@ -17,8 +17,8 @@ pkgbase = python-aiogram
optdepends = python-emoji: emojize and demojize support
optdepends = python-aioredis: Redis storage support
optdepends = python-aiohttp-socks: SOCKS4(a) and SOCKS5 proxy support
- source = https://github.com/aiogram/aiogram/archive/v2.6.tar.gz
- sha256sums = 7d790b9334a5b96f22ac4267a868a34bb233dfb19e8e9eba82f3d9d46fbbb39d
+ source = https://github.com/aiogram/aiogram/archive/v2.6.1.tar.gz
+ sha256sums = 5f5bdadc67a0a81d3c9a529cfbc694a09c7813ee32606b506401df955a99cb6b
pkgname = python-aiogram
diff --git a/PKGBUILD b/PKGBUILD
index 80355c5cb4c6..0e730ee5a848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
-pkgname='python-aiogram'
-pkgver=2.6
+_pyname='aiogram'
+pkgname="python-${_pyname}"
+pkgver=2.6.1
pkgrel=1
pkgdesc="A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp"
arch=('any')
-url="https://github.com/aiogram/aiogram"
+url="https://github.com/${_pyname}/${_pyname}"
license=('MIT')
depends=(
'python>=3.7'
@@ -15,7 +16,6 @@ depends=(
)
makedepends=(
'python-setuptools'
-# 'python-pip'
)
optdepends=(
'python-uvloop: fast, drop-in replacement of the built-in asyncio event loop'
@@ -26,26 +26,19 @@ optdepends=(
'python-aiohttp-socks: SOCKS4(a) and SOCKS5 proxy support'
# 'python-rethinkdb: RethinkDB storage support' # No such package yet
)
-source=("https://github.com/aiogram/aiogram/archive/v${pkgver}.tar.gz")
-# "no-pip.patch")
-sha256sums=('7d790b9334a5b96f22ac4267a868a34bb233dfb19e8e9eba82f3d9d46fbbb39d')
-# '6279e16e20acbae3e289cd0e5ba89db199753f35afa5201e3e8adbcd9c1653bb')
-
-#prepare() {
-# patch -u "$srcdir/aiogram-${pkgver}/setup.py" no-pip.patch
-#}
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('5f5bdadc67a0a81d3c9a529cfbc694a09c7813ee32606b506401df955a99cb6b')
build() {
- cd "$srcdir/aiogram-${pkgver}"
- python setup.py build
+ cd "$srcdir/${_pyname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "$srcdir/aiogram-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$srcdir/${_pyname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
}
# vim: ft=sh ts=4 sw=4 et
-