summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12018-12-26 00:02:10 +0500
committerevgfilim12018-12-26 00:02:10 +0500
commitf43d87aceac1d18079900c6630a2242d08619191 (patch)
tree8ff7e88ee568d346d6ea43ee3aec8979cd6144a9
downloadaur-f43d87aceac1d18079900c6630a2242d08619191.tar.gz
Initial commit, v2.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86442609e530
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-aiogram
+ pkgdesc = A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/aiogram/aiogram
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python>=3.7
+ depends = python-aiohttp>=3.4.4
+ depends = python-babel>=2.6.0
+ depends = python-certifi>=2018.8.24
+ optdepends = python-uvloop: fast, drop-in replacement of the built-in asyncio event loop
+ optdepends = python-ujson: ultra fast JSON encoder and decoder written in pure C
+ source = https://github.com/aiogram/aiogram/archive/v2.0.tar.gz
+ sha256sums = 9091d17f875186ee1b023f49f65e7c42cbe10339c2baa05649fa7c6dbd81a589
+
+pkgname = python-aiogram
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beeab92ba06e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
+
+pkgname='python-aiogram'
+pkgver=2.0
+pkgrel=1
+pkgdesc="A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp"
+arch=('any')
+url="https://github.com/aiogram/aiogram"
+license=('MIT')
+depends=('python>=3.7' 'python-aiohttp>=3.4.4' 'python-babel>=2.6.0' 'python-certifi>=2018.8.24')
+makedepends=('python-setuptools' 'python-pip')
+optdepends=('python-uvloop: fast, drop-in replacement of the built-in asyncio event loop'
+ 'python-ujson: ultra fast JSON encoder and decoder written in pure C')
+source=("https://github.com/aiogram/aiogram/archive/v${pkgver}.tar.gz")
+sha256sums=('9091d17f875186ee1b023f49f65e7c42cbe10339c2baa05649fa7c6dbd81a589')
+
+build() {
+ cd "$srcdir/aiogram-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/aiogram-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim: ft=sh ts=4 sw=4 et
+