summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Tuz2024-04-05 22:24:15 +0200
committerŁukasz Tuz2024-04-05 22:24:15 +0200
commit4463be0e72686cfa0f48452c5427332b9a970d5b (patch)
tree710e4e7b619a0a667b1e719ae4375407a3e527ec
downloadaur-4463be0e72686cfa0f48452c5427332b9a970d5b.tar.gz
Initial commit of aiohappyeyeballs package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3dba2da5a66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-aiohappyeyeballs
+ pkgdesc = Python library that provides happy eyeballs algorithm for asyncio.
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = https://github.com/aio-libs/aiohappyeyeballs
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/a/aiohappyeyeballs/aiohappyeyeballs-2.3.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = python-aiohappyeyeballs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..738abe704c2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Łukasz Tuz <lukasz.tuz@gmail.com>
+
+pkgname=python-aiohappyeyeballs
+pkgver=2.3.2
+pkgrel=1
+pkgdesc="Python library that provides happy eyeballs algorithm for asyncio."
+arch=('any')
+url="https://github.com/aio-libs/aiohappyeyeballs"
+license=('MIT')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/a/aiohappyeyeballs/aiohappyeyeballs-${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd aiohappyeyeballs-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd aiohappyeyeballs-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}