summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Brains2017-06-21 17:29:28 +0300
committerJoseph Brains2017-06-21 17:29:28 +0300
commit394f1b7177dd99f135c10ba265f820dc16876975 (patch)
treea6c6409cb1c7be006b09d000fbecaff1a8087077
downloadaur-394f1b7177dd99f135c10ba265f820dc16876975.tar.gz
Initial commit for python-aiohttp-cors GNS3 2x locked
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d57ec1481631
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-aiohttp-cors-gns3
+ pkgdesc = CORS support for aiohttp (GNS3)
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/aiohttp-cors
+ arch = any
+ groups = gns3
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-aiohttp-gns3
+ provides = python-aiohttp-cors
+ conflicts = python-aiohttp-cors
+ source = https://files.pythonhosted.org/packages/source/a/aiohttp-cors/aiohttp-cors-0.5.1.tar.gz
+ md5sums = 0ea7e6a2401b140009e58b791dfbbaca
+
+pkgname = python-aiohttp-cors-gns3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6134eada05a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Joseph Brains <jnbrains@gmail.com>
+_pkgname=aiohttp-cors
+pkgname=python-${_pkgname}-gns3
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="CORS support for aiohttp (GNS3)"
+arch=("any")
+url="https://pypi.python.org/pypi/${_pkgname}"
+license=('Apache')
+groups=('gns3')
+depends=('python' 'python-aiohttp-gns3')
+makedepends=('python-setuptools')
+provides=("python-${_pkgname}")
+conflicts=("python-${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz")
+md5sums=('0ea7e6a2401b140009e58b791dfbbaca')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}