summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2020-11-14 01:09:10 +0000
committerJoaquim Monteiro2020-11-14 01:09:10 +0000
commit064f1344765d59dae3af8dc5373d46c35e227948 (patch)
tree57c9f50a3f415daef1b447dc8fc92949483cc16d
downloadaur-064f1344765d59dae3af8dc5373d46c35e227948.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7a52dafa1aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-aiohttp-socks-git
+ pkgdesc = Proxy connector for aiohttp. Supports SOCKS4(a), SOCKS5, HTTP (tunneling) as well as proxy chains. (Git version)
+ pkgver = v0.5.5.r0.g69bf922
+ pkgrel = 1
+ url = https://github.com/romis2012/aiohttp-socks
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-aiohttp
+ depends = python-socks
+ provides = python-aiohttp-socks
+ conflicts = python-aiohttp-socks
+ source = git+https://github.com/romis2012/aiohttp-socks.git
+ sha512sums = SKIP
+
+pkgname = python-aiohttp-socks-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b9e4f41ab30
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+aiohttp-socks/
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de7c321ff0ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: gmes78 <joaquim dot monteiro at protonmail dot com>
+
+pkgname=python-aiohttp-socks-git
+pkgver=v0.5.5.r0.g69bf922
+pkgrel=1
+pkgdesc="Proxy connector for aiohttp. Supports SOCKS4(a), SOCKS5, HTTP (tunneling) as well as proxy chains. (Git version)"
+arch=(any)
+url="https://github.com/romis2012/aiohttp-socks"
+license=("Apache")
+
+depends=("python" "python-aiohttp" "python-socks")
+makedepends=("git" "python-setuptools")
+provides=("python-aiohttp-socks")
+conflicts=("python-aiohttp-socks")
+
+source=("git+https://github.com/romis2012/aiohttp-socks.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "aiohttp-socks"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "aiohttp-socks"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}