summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-07 14:18:14 -0600
committerMark Wagie2021-07-07 14:18:14 -0600
commit79a5f1d23bebddaa2f11699357a102b224f952cb (patch)
tree214941a60136dababb092a3096b1bb4eeb4e2809
parenta577a0e5fa30e51277f7270e20ebbdcd440c34c1 (diff)
downloadaur-79a5f1d23bebddaa2f11699357a102b224f952cb.tar.gz
0.5.11
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--requirements.txt16
3 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a5917e35e63..cff9a7e84d66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-aiopath
pkgdesc = Asynchronous pathlib for Python
- pkgver = 0.5.8
+ pkgver = 0.5.11
pkgrel = 1
url = https://github.com/alexdelorenzo/aiopath
arch = any
@@ -8,9 +8,8 @@ pkgbase = python-aiopath
makedepends = python-setuptools
depends = python-aiofile
depends = python-anyio
- source = https://pypi.org/packages/source/a/aiopath/aiopath-0.5.8.tar.gz
- source = requirements.txt
- sha256sums = 9d45cfacb01a0de619c5ff1b69ccbd9d4721fb58ee5a8b7bab163976fef42d1f
- sha256sums = 0bc99fef1d99908d4bd35a9bc81345124f1ebf4a7f12ac93327beac7cf7dca2d
+ depends = python-typing-extensions
+ source = aiopath-0.5.11.tar.gz::https://github.com/alexdelorenzo/aiopath/archive/refs/tags/v0.5.11.tar.gz
+ sha256sums = e80dd9d4c0e69e65d9b2758a849103b72c3ce1a6ffb8f6294703eaa5778e73ca
pkgname = python-aiopath
diff --git a/PKGBUILD b/PKGBUILD
index c10d95d5300f..29428935afee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-aiopath
_name=${pkgname#python-}
-pkgver=0.5.8
+pkgver=0.5.11
pkgrel=1
pkgdesc="Asynchronous pathlib for Python"
arch=('any')
url="https://github.com/alexdelorenzo/aiopath"
license=('LGPL3')
-depends=('python-aiofile' 'python-anyio')
+depends=('python-aiofile' 'python-anyio' 'python-typing-extensions')
makedepends=('python-setuptools')
-source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
- 'requirements.txt')
-#source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('9d45cfacb01a0de619c5ff1b69ccbd9d4721fb58ee5a8b7bab163976fef42d1f'
- '0bc99fef1d99908d4bd35a9bc81345124f1ebf4a7f12ac93327beac7cf7dca2d')
-
-prepare() {
- cp requirements.txt "$_name-$pkgver"
-}
+#source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('e80dd9d4c0e69e65d9b2758a849103b72c3ce1a6ffb8f6294703eaa5778e73ca')
build() {
cd "$_name-$pkgver"
diff --git a/requirements.txt b/requirements.txt
index c15e7130f6f6..539a9d0d5149 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,11 +1,15 @@
# Automatically generated by https://github.com/damnever/pigar.
-# aiopath-0.5.8/aiopath/handle.py: 8
+# aiopath-0.5.11/aiopath/handle.py: 10
aiofile == 3.5.1
-# aiopath-0.5.8/aiopath/path.py: 10
-# aiopath-0.5.8/aiopath/wrap.py: 4
-anyio == 3.2.0
+# aiopath-0.5.11/aiopath/handle.py: 9
+# aiopath-0.5.11/aiopath/path.py: 10
+# aiopath-0.5.11/aiopath/wrap.py: 4
+anyio == 3.2.1
-# aiopath-0.5.8/setup.py: 3
-setuptools == 57.0.0
+# aiopath-0.5.11/setup.py: 3
+setuptools == 57.1.0
+
+# aiopath-0.5.11/aiopath/types.py: 7
+typing_extensions == 3.10.0.0