summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-06-05 12:42:47 +1000
committerLuis Aranguren2019-06-05 12:42:47 +1000
commit2d0b048ad4bc6cf1dc62bc9b361cf3f25c3c98b3 (patch)
tree58310b0376c9a19392338aa49b83f108cda733c9
downloadaur-2d0b048ad4bc6cf1dc62bc9b361cf3f25c3c98b3.tar.gz
pkgver 0.18.3, inital commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77a5681c07b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-aiorpcx-git
+ pkgdesc = A generic asyncio library implementation of RPC suitable for an application that is a client, server or both.
+ pkgver = 0.18.3.r0.g4f39366
+ pkgrel = 1
+ url = https://github.com/kyuupichan/aiorpcX/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python>=3.6
+ depends = python-attrs
+ conflicts = python-aiorpcx
+ source = git://github.com/kyuupichan/aiorpcX.git
+ sha256sums = SKIP
+
+pkgname = python-aiorpcx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9044b1bf249a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Based on python-aiorpcx https://www.archlinux.org/packages/community/any/python-aiorpcx/ by Santiago Torres-Arias <santiago@archlinux.org>
+
+pkgname='python-aiorpcx-git'
+_gitname='aiorpcX'
+pkgver=0.18.3.r0.g4f39366
+pkgrel=1
+pkgdesc="A generic asyncio library implementation of RPC suitable for an application that is a client, server or both."
+url="https://github.com/kyuupichan/aiorpcX/"
+arch=('any')
+license=('MIT')
+conflicts=('python-aiorpcx')
+depends=('python>=3.6' 'python-attrs')
+makedepends=('python-setuptools' 'git')
+source=("git://github.com/kyuupichan/aiorpcX.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 LICENCE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}