summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2018-12-26 22:08:16 -0600
committerSam Whited2018-12-26 22:08:46 -0600
commit166d3034ed7feb8b8014a09565a38c3c5443ef3a (patch)
tree927a40ba89e086dcf3ebc23cff646644d614e7a6
parentf75cc1ba7120aa71dbb12f1180290206f5d58bb0 (diff)
downloadaur-166d3034ed7feb8b8014a09565a38c3c5443ef3a.tar.gz
Bump to v0.4.0 and minor tweaks
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e70e307637e..c5c707747b0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Sep 30 10:09:11 UTC 2017
pkgbase = python-aiosasl
pkgdesc = A pure python generic asyncio SASL library
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/horazont/aiosasl
arch = any
@@ -10,8 +8,8 @@ pkgbase = python-aiosasl
checkdepends = python-nose
makedepends = python-setuptools
depends = python
- source = https://github.com/horazont/aiosasl/archive/v0.3.1.tar.gz
- sha512sums = ba5efbd38b0c8113b9dfa62d172259f79cc6a15071b3d85e22ba853cb19182b717c3e123babaf8aa43fe731293a25d71c0ef517d8e38a685691801d81a43e31f
+ source = https://github.com/horazont/aiosasl/archive/v0.4.0.tar.gz
+ sha256sums = 6cf620672b64669b9136ab73e42f022d95a328385bff5053080356fdbb129f82
pkgname = python-aiosasl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f40aaba69670
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 13c399a50e0b..8424b08f98af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: renek <aur@spaceshore.net>
-_pkgname=aiosasl
-pkgname=python-${_pkgname}
-pkgver=0.3.1
+# Maintainer: Sam Whited <sam@samwhited.com>
+# Contributor: renek <aur@spaceshore.net>
+
+pkgname=python-aiosasl
+pkgver=0.4.0
pkgrel=1
pkgdesc="A pure python generic asyncio SASL library"
arch=('any')
@@ -10,15 +11,17 @@ license=('LGPL3')
depends=('python')
makedepends=('python-setuptools')
checkdepends=('python-nose')
-source=("https://github.com/horazont/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('ba5efbd38b0c8113b9dfa62d172259f79cc6a15071b3d85e22ba853cb19182b717c3e123babaf8aa43fe731293a25d71c0ef517d8e38a685691801d81a43e31f')
+source=("https://github.com/horazont/aiosasl/archive/v${pkgver}.tar.gz")
+sha256sums=('6cf620672b64669b9136ab73e42f022d95a328385bff5053080356fdbb129f82')
check() {
- cd "$_pkgname-$pkgver"
- python -m nose
+ cd "aiosasl-$pkgver"
+ python -m nose
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "aiosasl-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
}
+
+# vim: ts=2 sw=2 et: