summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2016-10-03 14:28:24 +0800
committerPeter Cai2016-10-03 14:28:24 +0800
commitb96d5819eb68c8a818e59ffa2379162748ec6127 (patch)
tree42580b669ce1f40f1106fa812862e4777abe7cc2
downloadaur-b96d5819eb68c8a818e59ffa2379162748ec6127.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD23
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10454c5a7005
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-aiosocks
+ pkgdesc = SOCKS proxy client for asyncio and aiohttp
+ pkgver = 0.1.7
+ pkgrel = 1
+ arch = any
+ license = APACHE-2
+ depends = python>=3.4
+ depends = python-setuptools
+ optdepends = python-aiohttp: For aiosocks.SocksConnector
+ source = https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip
+ md5sums = 46b2c6564e8af97ce6a8ad66fe632de3
+
+pkgname = python-aiosocks
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fc7b0b974eb0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ecec7a52e58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Peter Cai <peter at typeblog dot net>
+
+_pkgname=aiosocks
+pkgname=python-aiosocks
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="SOCKS proxy client for asyncio and aiohttp"
+arch=("any")
+license=("APACHE-2")
+depends=("python>=3.4" "python-setuptools")
+optdepends=("python-aiohttp: For aiosocks.SocksConnector")
+source=("https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip")
+md5sums=('46b2c6564e8af97ce6a8ad66fe632de3')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}