summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2016-10-03 17:51:51 +0800
committerlilac2016-10-03 17:51:51 +0800
commite0e4a307b5d4d6b3b2651892102fdcb0742f2f30 (patch)
treecd36ae87e2ec110704e5bbb0086f18e1a9bd2690
parent57b744421389975e4cc3a93f031e990e51bfff7c (diff)
downloadaur-e0e4a307b5d4d6b3b2651892102fdcb0742f2f30.tar.gz
update by lilac
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d75b2f10f8c1..55ae09ebb4fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Mon Oct 3 09:51:51 UTC 2016
pkgbase = python-aiosocks
pkgdesc = SOCKS proxy client for asyncio and aiohttp
pkgver = 0.1.7
@@ -5,9 +7,8 @@ pkgbase = python-aiosocks
url = https://github.com/nibrag/aiosocks
arch = any
license = Apache
- depends = python>=3.4
+ depends = python
depends = python-setuptools
- optdepends = python-aiohttp: For aiosocks.SocksConnector
source = https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip
md5sums = 46b2c6564e8af97ce6a8ad66fe632de3
diff --git a/PKGBUILD b/PKGBUILD
index 5baa4514bb1f..e606da891c6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
-# Maintainer: Peter Cai <peter at typeblog dot net>
-
_pkgname=aiosocks
pkgname=python-aiosocks
pkgver=0.1.7
pkgrel=1
pkgdesc="SOCKS proxy client for asyncio and aiohttp"
+arch=('any')
url="https://github.com/nibrag/aiosocks"
-arch=("any")
-license=("Apache")
-depends=("python>=3.4" "python-setuptools")
-optdepends=("python-aiohttp: For aiosocks.SocksConnector")
-source=("https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip")
+license=('Apache')
+depends=('python' 'python-setuptools')
+source=('https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip')
md5sums=('46b2c6564e8af97ce6a8ad66fe632de3')
build() {
@@ -20,5 +17,8 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
+
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
}
+
+# vim:set sw=2 et: