summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-12-05 04:40:22 +0800
committerlilac2020-12-05 04:40:22 +0800
commitfc603899ede87fb158f1e345bfff0654d3ae5d2a (patch)
tree410726d5ff5f819fd5c1994812fbc5982d6bd53d
parent9923a15ecb57b274ef58c68a469b364a25c370da (diff)
downloadaur-fc603899ede87fb158f1e345bfff0654d3ae5d2a.tar.gz
[lilac] updated to 0.2.6-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae36e52097a1..b15543967230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-aiosocks
pkgdesc = SOCKS proxy client for asyncio and aiohttp
pkgver = 0.2.6
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/nibrag/aiosocks
arch = any
- license = Apache
+ license = Apache 2
depends = python
depends = python-setuptools
source = https://files.pythonhosted.org/packages/source/a/aiosocks/aiosocks-0.2.6.tar.gz
- md5sums = cbe53d1ff7c4537b66d5515d90ac1bc5
+ sha256sums = 94dfb2c3ff2fc646c88629e29872599cc93d9137c2eace68dc89079e6a221277
pkgname = python-aiosocks
diff --git a/PKGBUILD b/PKGBUILD
index 99e02f6be36f..d4a237ee042a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
-_pkgname=aiosocks
+_name=aiosocks
pkgname=python-aiosocks
pkgver=0.2.6
-pkgrel=2
+pkgrel=4
pkgdesc="SOCKS proxy client for asyncio and aiohttp"
arch=('any')
url="https://github.com/nibrag/aiosocks"
-license=('Apache')
+license=('Apache 2')
depends=('python' 'python-setuptools')
-_name=${pkgname#python-}
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('cbe53d1ff7c4537b66d5515d90ac1bc5')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/aiosocks-0.2.6.tar.gz")
+sha256sums=('94dfb2c3ff2fc646c88629e29872599cc93d9137c2eace68dc89079e6a221277')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py build
+ cd "$srcdir/aiosocks-0.2.6"
+ python3 setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/aiosocks-0.2.6"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+
+ # make sure we don't install any world-writable or root-readable-only files
+ # we shouldn't need to fix ownership as we extract tarballs as a non-root user
+ # https://github.com/pypa/setuptools/issues/1328
+ # https://github.com/LonamiWebs/Telethon/issues/1605
+ chmod u=rwX,go=rX -R "$pkgdir"
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
}
-# vim:set sw=2 et: