summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2018-12-26 22:17:59 -0600
committerSam Whited2018-12-26 22:17:59 -0600
commitaf21a305b698b5193a62579dbe64e1286f8ff621 (patch)
tree4c8e2320a1360a83d782d386e813785a82402a09
parent0e7a9120adbdfbba2f213f6ca7fc68e96d14757f (diff)
downloadaur-af21a305b698b5193a62579dbe64e1286f8ff621.tar.gz
Bump to v0.10.1 and pull from PyPi
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
2 files changed, 31 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f40aaba69670
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 464ede93af7c..a1d4664a4c8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,39 @@
-# Maintainer: renek <aur@spaceshore.net>
-_pkgname=aioxmpp
-pkgname=python-${_pkgname}
-pkgver=0.9.1
+# Maintainer: Sam Whited <sam@samwhited.com>
+# Contributor: renek <aur@spaceshore.net>
+
+pkgname=python-aioxmpp
+_name=${pkgname#python-}
+pkgver=0.10.1
pkgrel=1
pkgdesc="An XMPP library for use with Python 3.4 asyncio"
arch=('any')
url="https://github.com/horazont/aioxmpp"
license=('LGPL3')
-depends=('python' 'python-dnspython' 'libxml2' 'python-lxml'
-'python-orderedset' 'python-tzlocal' 'python-pyopenssl' 'python-pyasn1' 'python-pyasn1-modules' 'python-aiosasl' 'python-multidict' 'python-babel')
+depends=('python'
+ 'libxml2'
+ 'python-aiosasl'
+ 'python-babel'
+ 'python-dnspython'
+ 'python-lxml'
+ 'python-multidict'
+ 'python-orderedset'
+ 'python-pyasn1'
+ 'python-pyasn1-modules'
+ 'python-pyopenssl'
+ 'python-tzlocal')
makedepends=('python-setuptools')
checkdepends=('python-nose')
-source=("https://github.com/horazont/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('abc6e427221ea87761f1f80090d70a54397e7e6d9909036a95bcbc229c36a7c235418d728304e256c0bd4f0ed10ec703fbfd6abb40a5d249c894a6711b9f3bfe')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('6eb4e4485fb12301d23224f41f85f81b82767098db295c9803a05949fa2f50f9')
check() {
- cd "$_pkgname-$pkgver"
- python -m nose
+ cd "aioxmpp-$pkgver"
+ python -m nose
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "aioxmpp-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
}
+
+# vim:set ts=2 sw=2 et: