summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2018-10-02 20:17:37 +0200
committerEmmanuel Gil Peyrot2018-10-02 20:17:37 +0200
commitbf360a81239e1ff34cf3b7e1d953b3cea63b28af (patch)
tree899ac63157fe332a8faac5052aee513f78dbf9ce
parent539f8cacdcb5637d1a89307a92ee8f5ae4e3fce0 (diff)
downloadaur-bf360a81239e1ff34cf3b7e1d953b3cea63b28af.tar.gz
Split package() into build() and package().
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02d26b2395cc..8d4540e96b29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,9 +31,14 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
package() {
cd $pkgname
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
# vim:set ts=2 sw=2 et: