summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-04-17 18:46:26 +0200
committerChristopher Arndt2021-04-17 18:46:26 +0200
commit3bd53212b8a46ea628e7b2ed627de9c75fc9b389 (patch)
tree598ce5721f87f4da98019759680fcd6548c253e1
parent92a0ad72543d35ae63ce10e480e1d0a6f4e8c4cc (diff)
downloadaur-python-airnef.tar.gz
Update patch to add missing module import
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--airnef-linux.patch33
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de1ef84551a0..61b5f2c4a223 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-airnef
pkgdesc = Wireless download from your Nikon/Sony/Canon camera
pkgver = 1.1
- pkgrel = 4
+ pkgrel = 5
url = https://testcams.com/airnef/
arch = any
license = GPL3
@@ -10,7 +10,7 @@ pkgbase = python-airnef
source = https://testcams.com/airnef/Version_1.1/airnef_v1.1_Source.zip
source = airnef-linux.patch
sha512sums = b45b0591e42179d1e5b5eea9ede6762d311cd0642585c54568c90111424e2ca316aa444d772b4855afe42f25b6cc4b3e1b78bb5a0c2a4cb52440535894a5cba6
- sha512sums = c0337540e1e65cee3d6f4bc3610b6d2d2a72b7f97a0197f5dd27768a5f42f1e4e5e936ce059ff4daf9aa95faa5613228306d6d3f4f2f7ed42c5566521138c24d
+ sha512sums = 2ebf9eda9c354f73a1a3084eca706c1d30d67737101d5bfb69474984f636ce5dc52092cec3de2d04e8ac61afa26ffe78e41dbf1a2fee5955af2ceed75620f154
pkgname = python-airnef
diff --git a/PKGBUILD b/PKGBUILD
index e5052c99808e..e858b928cd90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=airnef
pkgname="python-${_name}"
pkgver=1.1
-pkgrel=4
+pkgrel=5
pkgdesc="Wireless download from your Nikon/Sony/Canon camera"
arch=('any')
url="https://testcams.com/airnef/"
@@ -12,7 +12,7 @@ depends=('python' 'tk')
source=("https://testcams.com/airnef/Version_1.1/airnef_v1.1_Source.zip"
"airnef-linux.patch")
sha512sums=('b45b0591e42179d1e5b5eea9ede6762d311cd0642585c54568c90111424e2ca316aa444d772b4855afe42f25b6cc4b3e1b78bb5a0c2a4cb52440535894a5cba6'
- 'c0337540e1e65cee3d6f4bc3610b6d2d2a72b7f97a0197f5dd27768a5f42f1e4e5e936ce059ff4daf9aa95faa5613228306d6d3f4f2f7ed42c5566521138c24d')
+ '2ebf9eda9c354f73a1a3084eca706c1d30d67737101d5bfb69474984f636ce5dc52092cec3de2d04e8ac61afa26ffe78e41dbf1a2fee5955af2ceed75620f154')
DLAGENTS=('https::/usr/bin/curl --insecure -fLC - --retry 3 --retry-delay 3 -o %o %u')
diff --git a/airnef-linux.patch b/airnef-linux.patch
index 9321b9fe8d59..605a4d0a8b28 100644
--- a/airnef-linux.patch
+++ b/airnef-linux.patch
@@ -1,6 +1,6 @@
diff -uNrb airnef/airnefcmd.py airnef.new/airnefcmd.py
--- airnef/airnefcmd.py 2015-10-07 13:49:44.000000000 +0200
-+++ airnef.new/airnefcmd.py 2019-01-28 22:43:14.207678865 +0100
++++ airnef.new/airnefcmd.py 2021-04-17 18:38:09.950093592 +0200
@@ -134,6 +134,7 @@
self.isWin32 = None # True if we're running on a Windows platform
@@ -30,8 +30,31 @@ diff -uNrb airnef/airnefcmd.py airnef.new/airnefcmd.py
g.appDataDir = os.path.join(g.appDir, "appdata")
diff -uNrb airnef/airnef.pyw airnef.new/airnef.pyw
--- airnef/airnef.pyw 2015-10-08 09:57:00.000000000 +0200
-+++ airnef.new/airnef.pyw 2019-01-28 22:43:14.211012198 +0100
-@@ -104,6 +104,7 @@
++++ airnef.new/airnef.pyw 2021-04-17 18:41:38.719793894 +0200
+@@ -45,15 +45,17 @@
+ from six.moves import tkinter_ttk as ttk
+ from six.moves import tkinter_tkfiledialog as tkFileDialog
+ from six.moves import tkinter_messagebox as tkMessageBox
+-import time
+-import subprocess
+-import os
++
++import datetime
+ import errno
+-import platform
+ import json
+-import datetime
++import os
++import platform
++import re
+ import signal
++import subprocess
+ import sys
++import time
+
+ #
+ # constants
+@@ -104,6 +106,7 @@
def __init__(self):
self.isWin32 = None # True if we're running on a Windows platform
self.isOSX = None # True if we're runnong on an OSX platform
@@ -39,7 +62,7 @@ diff -uNrb airnef/airnef.pyw airnef.new/airnef.pyw
self.isFrozen = None # True if we're running in a pyintaller frozen environment (ie, built as an executable)
self.appDir = None # directory where script is located. this path is used to store all metadata files, in case script is run in different working directory
self.appDataDir = None # directory where we keep app metadata
-@@ -1202,6 +1203,7 @@
+@@ -1202,6 +1205,7 @@
g.isWin32 = (platform.system() == 'Windows')
g.isOSX = (platform.system() == 'Darwin')
@@ -47,7 +70,7 @@ diff -uNrb airnef/airnef.pyw airnef.new/airnef.pyw
g.isFrozen = (getattr(sys, 'frozen', False))
#
-@@ -1226,6 +1228,10 @@
+@@ -1226,6 +1230,10 @@
applicationSupportDir = os.path.join(userHomeDir, 'Library/Application Support')
if os.path.exists(applicationSupportDir): # probably not necessary to check existence since every system should have this directory
g.appDataDir = os.path.join(applicationSupportDir, 'airnef/appdata')