summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpozar2016-01-08 23:01:50 +0100
committerpozar2016-01-08 23:01:50 +0100
commit4ce4c64645fb6554e6fa763713ce277291c6d54d (patch)
treeba4e5ec878f1e2fb216fac7fa7222242b894fce7
parent6287896fd57616bf8c616bdc93e5a64777bf5e1b (diff)
downloadaur-4ce4c64645fb6554e6fa763713ce277291c6d54d.tar.gz
add support for python2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6546e3842ec2..84525c033638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jan 1 10:32:54 UTC 2016
+# Fri Jan 8 22:01:35 UTC 2016
pkgbase = python-airspeed
pkgdesc = Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java
pkgver = 0.5.4
@@ -14,3 +14,7 @@ pkgname = python-airspeed
depends = python
depends = python-six
+pkgname = python2-airspeed
+ depends = python2
+ depends = python2-six
+
diff --git a/PKGBUILD b/PKGBUILD
index 7463da4f1a73..cbbe604f41e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Lukasz Pozarlik <lpozarlik@gmail.com>
pkgbase=python-airspeed
-pkgname=('python-airspeed')
- #'python-airspeed')
+pkgname=('python-airspeed'
+ 'python2-airspeed')
pkgdesc="Airspeed is a powerful and easy-to-use templating engine for Python that aims for a high level of compatibility with the popular Velocity library for Java"
pkgver="0.5.4"
pkgrel=3
@@ -12,13 +12,6 @@ arch=('any')
source="https://pypi.python.org/packages/source/a/airspeed/airspeed-${pkgver}dev-20150515.tar.gz"
md5sums=('c49066864b16b169efda73d3b0583897')
-#package_python2-airspeed(){
-# depends=('python2'
-# 'python2-six')
-# cd "$srcdir/airspeed-${pkgver}dev-20150515"
-# python2 setup.py install --root="${pkgdir}/" --optimize=1
-#}
-
package_python-airspeed(){
depends=('python'
'python-six')
@@ -26,4 +19,10 @@ package_python-airspeed(){
python setup.py install --root="${pkgdir}/" --optimize=1
}
+package_python2-airspeed(){
+ depends=('python2'
+ 'python2-six')
+ cd "$srcdir/airspeed-${pkgver}dev-20150515"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}