summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Langlois2020-10-15 16:54:22 -0400
committerEric Langlois2020-10-15 16:54:22 -0400
commitf9facda434ad510db2aef8a3b4ea04afdc38daf5 (patch)
tree83ba0ee97aaa5b95bfad3b2f7492afc9ffa84d1b
parenta548946bcb65d412336192fab7e337805d092039 (diff)
downloadaur-f9facda434ad510db2aef8a3b4ea04afdc38daf5.tar.gz
upgpkg: python-akro 0.0.8-1
Fix package check(); cd into directory and use python -m pytest so that `arko` is added to PYTHONPATH
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb3e42dea64a..83e9b581bd6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,13 +28,14 @@ build() {
}
check() {
+ cd "$_name-$pkgver/build/lib"
# Test excludes:
# _tf: Requires tensorflow < 2, a large dependency
# _theano: Requires theano, a large dependency
# test_hash: Python hashes are not reproducible...
# TestBox::test_invalid_env: Tests gym.Box.__init__, and gym's error
# seems to have changed from what they expected.
- pytest "$_name-$pkgver/tests" \
+ python -m pytest "$srcdir/$_name-$pkgver/tests" \
-k 'not _tf and not _theano and not test_hash and not test_invalid_env'
}