summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Clayfield2019-12-21 12:03:40 +0800
committerMichael Clayfield2019-12-21 12:03:40 +0800
commite0cca67fddca01b446c6c16cb11e117276575238 (patch)
treea70a7c3077567cf8648dfa519862968fb30227d3
parentd2ac52463b8a83627204d09e7cb7f9ec26b04970 (diff)
downloadaur-e0cca67fddca01b446c6c16cb11e117276575238.tar.gz
Updated to v7.2.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc686ba9c8c..d9226a643431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-alerta-client
- pkgver = 5.0.12
+ pkgdesc = Unified CLI, terminal GUI and python SDK for the Alerta monitoring system
+ pkgver = 7.2.2
pkgrel = 1
url = https://github.com/alerta/python-alerta-client
arch = any
- license = MIT
+ license = APACHE
+ makedepends = python-setuptools
depends = python
- depends = python-requests
+ depends = python-click
depends = python-pytz
- depends = python-setuptools
+ depends = python-requests
depends = python-tabulate
- depends = python-click
- depends = python-six
- source = git+https://github.com/alerta/python-alerta-client.git#commit=3ba1079a272ace7721c97daa218a4b33fa306f8d
- sha256sums = SKIP
+ source = https://github.com/alerta/python-alerta-client/archive/v7.2.2.tar.gz
+ sha256sums = c7fdb09a1f9fc1df59393e50226d0ef131bb3a43948b942cbbfc9001d0842077
pkgname = python-alerta-client
diff --git a/PKGBUILD b/PKGBUILD
index 84f9bd5ea0d1..34d4bf347e6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
+# Maintainer: Michael Clayfield <me@michaelclayfield.com>
pkgname=python-alerta-client
-_pkgvergit=commit=3ba1079a272ace7721c97daa218a4b33fa306f8d
-pkgver=5.0.12
+pkgver=7.2.2
pkgrel=1
+pkgdesc="Unified CLI, terminal GUI and python SDK for the Alerta monitoring system"
arch=('any')
-url=https://github.com/alerta/python-alerta-client
-license=('MIT')
-depends=('python' 'python-requests' 'python-pytz' 'python-setuptools' 'python-tabulate' 'python-click' 'python-six')
-#makedepends=('python-setuptools')
-source=("git+https://github.com/alerta/python-alerta-client.git#$_pkgvergit")
-sha256sums=('SKIP')
+url="https://github.com/alerta/python-alerta-client"
+license=('APACHE')
+makedepends=('python-setuptools')
+depends=('python' 'python-click' 'python-pytz' 'python-requests' 'python-tabulate')
+source=("https://github.com/alerta/python-alerta-client/archive/v$pkgver.tar.gz")
+sha256sums=('c7fdb09a1f9fc1df59393e50226d0ef131bb3a43948b942cbbfc9001d0842077')
-pkgver() {
- cd "$pkgname"
- cat VERSION
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd $srcdir/$pkgname/
- python setup.py install --root $pkgdir
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
}