summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Quinn2018-09-03 21:08:11 +0100
committerDaniel Quinn2018-09-03 21:08:11 +0100
commit877ed7f33a6e84227bbf20869d73f23b59ed248a (patch)
tree1adaf5239ec36eff6c8bb5c0d55131c4b1f160ce
parent1b37b5df5e3d9c3b1c7a4113385573a51e26350c (diff)
downloadaur-877ed7f33a6e84227bbf20869d73f23b59ed248a.tar.gz
0.6.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbfe79f70f7a..206fb67ffe04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = python-aletheia
pkgdesc = Fight fake news with cryptography & human nature
- pkgver = 0.6.1
+ pkgver = 0.6.3
pkgrel = 1
url = https://danielquinn.github.io/aletheia
arch = any
license = AGPL3
- checkdepends = pytest
makedepends = python-setuptools
depends = ffmpeg
depends = python
@@ -16,8 +15,8 @@ pkgbase = python-aletheia
depends = python-requests
depends = python-termcolor
depends = python-piexif
- source = https://files.pythonhosted.org/packages/source/a/aletheia/aletheia-0.6.1.tar.gz
- sha512sums = d7a69dcbf2a0bb6c90c20d9e5c130a3bced492843256367492550e5a201a74f3e536a49ecc2dbea235cabaae7be9c3383a6df75c29c5d26844fa2b806dc7c445
+ source = https://files.pythonhosted.org/packages/source/a/aletheia/aletheia-0.6.3.tar.gz
+ sha512sums = 4734dfd2a86725a6cac29c56600b7e40b36bc34dbd08ce2727ce9669780ec21e1fe439039396c4c56a1acb2500d134892f3ee11731e27636d367d0a8cc4e1dd3
pkgname = python-aletheia
diff --git a/PKGBUILD b/PKGBUILD
index aa2902a0093e..056f2d67b11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Quinn <archlinux at danielquinn dot org>
pkgname="python-aletheia"
-pkgver=0.6.1
+pkgver=0.6.3
pkgrel=1
pkgdesc="Fight fake news with cryptography & human nature"
_name=${pkgname#python-}
@@ -18,9 +18,8 @@ depends=('ffmpeg'
'python-requests'
'python-termcolor'
'python-piexif')
-checkdepends=('pytest')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('d7a69dcbf2a0bb6c90c20d9e5c130a3bced492843256367492550e5a201a74f3e536a49ecc2dbea235cabaae7be9c3383a6df75c29c5d26844fa2b806dc7c445')
+sha512sums=('4734dfd2a86725a6cac29c56600b7e40b36bc34dbd08ce2727ce9669780ec21e1fe439039396c4c56a1acb2500d134892f3ee11731e27636d367d0a8cc4e1dd3')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -30,4 +29,6 @@ build() {
package() {
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
}