summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-07 22:29:44 -0500
committerCarlos Aznarán Laos2023-05-07 22:29:44 -0500
commitbf79bafbb0b5f786ec224ffb9ccad5437ce41b99 (patch)
treeab0ceb5c6dc2067d2426c3ed19c6b00b7283dafe
parent691a0f969ec928bbdb4353d12c79a4764ec91258 (diff)
downloadaur-bf79bafbb0b5f786ec224ffb9ccad5437ce41b99.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e4f52aa1ba3..1951806b7749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = python-algopy
url = https://pythonhosted.org/algopy
arch = any
license = custom
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-scipy
source = https://pypi.org/packages/source/a/algopy/algopy-0.5.7.zip
sha512sums = 1d2cb62154f7bc344605e2db1d90125a76b93e99628056ef007a27b05546d0af3e1d52587dc3217d03118f8dddac298742c303ae9d39185ab33375e56ae3a1ba
diff --git a/PKGBUILD b/PKGBUILD
index afdb0b533081..0b68966cf4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
# Contributor: Hector <hsearaDOTatDOTgmailDOTcom>
_base=algopy
pkgname=python-${_base}
+pkgdesc="A library for Automatic Differentation in Python"
pkgver=0.5.7
pkgrel=2
-pkgdesc="A library for Automatic Differentation in Python"
+arch=(any)
url="https://pythonhosted.org/${_base}"
license=('custom')
-arch=('any')
depends=(python-scipy)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.zip)
sha512sums=('1d2cb62154f7bc344605e2db1d90125a76b93e99628056ef007a27b05546d0af3e1d52587dc3217d03118f8dddac298742c303ae9d39185ab33375e56ae3a1ba')
build() {
- cd "${_base}-${pkgver}"
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "${_base}-${pkgver}"
- export PYTHONHASHSEED=0
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
}