summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-12 21:22:27 -0500
committerLuis Martinez2021-09-12 21:22:27 -0500
commit41debd93bd1af57ed39831d43e2862d1d04ac76b (patch)
treecb9e17e31bd4d584418e53b63bb3ed454f8bb00f
parentdeea3bff05120d7ce01d85145c91dd4fe29e9fbd (diff)
downloadaur-41debd93bd1af57ed39831d43e2862d1d04ac76b.tar.gz
package cleanup
-rw-r--r--.SRCINFO12
-rw-r--r--CHANGES.txt28
-rw-r--r--PKGBUILD43
3 files changed, 56 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c83af3c002d..61b1e2a52f97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = python-allpairspy
- pkgdesc = A python library for test combinations generator
+ pkgdesc = Python library for test combinations generator
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thombashi/allpairspy
arch = any
license = MIT
- checkdepends = python-pytest
+ checkdepends = python-pytest-runner
makedepends = python-setuptools
- makedepends = python-six
depends = python
- source = https://github.com/thombashi/allpairspy/archive/v2.5.0.tar.gz
- sha256sums = 4af06f6af70d53f126daf04fda82ae1dbb8517b0bdad0f55aaa5e04f3d9daa6a
+ source = python-allpairspy-2.5.0.tar.gz::https://files.pythonhosted.org/packages/source/a/allpairspy/allpairspy-2.5.0.tar.gz
+ sha256sums = 9358484c91abe74ba18daf9d6d6904c5be7cc8818397d05248c9d336023c28b1
pkgname = python-allpairspy
-
diff --git a/CHANGES.txt b/CHANGES.txt
new file mode 100644
index 000000000000..81d3b591cabc
--- /dev/null
+++ b/CHANGES.txt
@@ -0,0 +1,28 @@
+Version 2.0.1 (April 4, 2009):
+
+ - Moved examples into their own directory.
+
+ - 'example2.2.py' re-written to get rid of frivolous usage of
+ decorators (thanks to Tennis Smith for bringing
+ the example's apparent complexity to our attention).
+
+ - Easier installation through distutils-based setup.py script.
+
+ - Created AllPairs project on SourceForge.net with home page at
+ http://apps.sourceforge.net/trac/allpairs/.
+
+ - Submitted the project to the Python Package Index at
+ http://pypi.python.org/pypi.
+
+
+Version 2.0 (December 2007):
+
+ - Ability to produce n-wise combinations.
+ - Released as open source to MetaCommunications Engineering
+ website (http://engineering.meta-comm.com).
+
+
+Version 1.0 (May 2002):
+
+ Initial version, widely adopted at MetaCommunications Inc. for
+ multiple testing projects.
diff --git a/PKGBUILD b/PKGBUILD
index 4a04d86f079e..48c3e9f7c272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
-pkgname='python-allpairspy'
-_module='allpairspy'
-pkgver='2.5.0'
-pkgrel=1
-pkgdesc='A python library for test combinations generator'
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: vanyasem
+
+pkgname=python-allpairspy
+pkgver=2.5.0
+pkgrel=2
+pkgdesc='Python library for test combinations generator'
+arch=('any')
+license=('MIT')
url='https://github.com/thombashi/allpairspy'
+changelog=CHANGES.txt
depends=('python')
-makedepends=('python-setuptools' 'python-six')
-checkdepends=('python-pytest')
-license=('MIT')
-arch=('any')
-source=("https://github.com/thombashi/allpairspy/archive/v${pkgver}.tar.gz")
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-runner')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('4af06f6af70d53f126daf04fda82ae1dbb8517b0bdad0f55aaa5e04f3d9daa6a')
-BUILDENV+=('!check')
-
-check() {
- cd "${srcdir}/${_module}-${pkgver}"
- pytest
+build() {
+ cd "allpairspy-$pkgver"
+ python setup.py build
}
-build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+check() {
+ cd "allpairspy-$pkgver"
+ python setup.py pytest
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "allpairspy-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
}