summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-11 16:45:35 -0500
committerCarlos Aznarán2024-03-11 16:45:35 -0500
commit1973ffbec9c8843cf91d6ada70e17eb410236404 (patch)
tree69e26ecf5cf6a91bd402f3a61ff5d655bbf28aae
parent46dba8113257b7cdf52b756b2650c18ac1eef834 (diff)
downloadaur-1973ffbec9c8843cf91d6ada70e17eb410236404.tar.gz
Bump version to 2.13.3
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD21
4 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b660b485fcf9..d0e90006242b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-allure-commons
pkgdesc = Common module for integrate allure with python-based frameworks
- pkgver = 2.13.2
+ pkgver = 2.13.3
pkgrel = 1
url = https://github.com/allure-framework/allure-python
arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools-scm
- makedepends = git
- depends = python-pluggy
+ makedepends = python-wheel
depends = python-attrs
- source = git+https://github.com/allure-framework/allure-python.git#tag=2.13.2
- sha512sums = SKIP
+ depends = python-pluggy
+ source = allure-python-2.13.3.tar.gz::https://github.com/allure-framework/allure-python/archive/2.13.3.tar.gz
+ sha512sums = cc0a7b4181ecc482ff10cbcacbfe47068329f7c4dfa659998957f13619d5c63765e94aec272e843179580040c8e044a774948ddd95c164f377b0714f6abb9011
pkgname = python-allure-commons
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..1c2e62a6151c
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-allure-commons]
+source = "github"
+github = "allure-framework/allure-python"
+use_latest_release = "true" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 161b705abf58..e9cd47c49502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# Contributor: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
_base=allure
pkgname=python-${_base}-commons
-pkgver=2.13.2
+pkgver=2.13.3
pkgrel=1
pkgdesc="Common module for integrate allure with python-based frameworks"
arch=(any)
url="https://github.com/${_base}-framework/${_base}-python"
-depends=(python-pluggy python-attrs)
-makedepends=(python-setuptools-scm git)
-source=("git+${url}.git#tag=${pkgver}")
-sha512sums=('SKIP')
+license=(Apache-2.0)
+depends=(python-attrs python-pluggy)
+makedepends=(python-build python-installer python-setuptools-scm python-wheel)
+source=(${_base}-python-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('cc0a7b4181ecc482ff10cbcacbfe47068329f7c4dfa659998957f13619d5c63765e94aec272e843179580040c8e044a774948ddd95c164f377b0714f6abb9011')
build() {
- cd ${_base}-python/${_base}-python-commons
- python setup.py build
+ cd ${_base}-python-${pkgver}/${_base}-python-commons
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd ${_base}-python/${_base}-python-commons
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ cd ${_base}-python-${pkgver}/${_base}-python-commons
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 ${srcdir}/${_base}-python-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}