summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-12-11 11:24:59 -0500
committerCarlos Aznarán Laos2021-12-11 11:24:59 -0500
commitabe77070a650aa7b0cbadcb22050c81614cfd1f5 (patch)
tree04f228acf63b86cb307a41bd4a1870922d6112ac
parent5c655a7e6e3d2bb3dc97318b942182e8a01c6be4 (diff)
downloadaur-abe77070a650aa7b0cbadcb22050c81614cfd1f5.tar.gz
Version bump to 2.9.45
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c2e69506b64..ebd62a1cf6f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-allure-commons
- pkgdesc = Commons of Allure python adaptors for python-based test frameworks
- pkgver = 2.5.3
+ pkgdesc = Common module for integrate allure with python-based frameworks
+ pkgver = 2.9.45
pkgrel = 1
- url = https://github.com/allure-framework/allure-python/tree/master/allure-python-commons
+ url = https://github.com/allure-framework/allure-python
arch = any
- depends = python
- depends = python-pluggy>=0.4.0
- depends = python-six>=1.9.0
- depends = python-attrs>=16.0.0
- source = git+https://github.com/allure-framework/allure-python.git#tag=2.5.3
- md5sums = SKIP
+ makedepends = python-setuptools-scm
+ makedepends = git
+ depends = python-pluggy
+ depends = python-six
+ depends = python-attrs
+ source = git+https://github.com/allure-framework/allure-python.git#tag=2.9.45
+ sha512sums = SKIP
pkgname = python-allure-commons
-
diff --git a/PKGBUILD b/PKGBUILD
index 2ff1eb9d26df..f01433128bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Pavel Merzlyakov <pavel.merzlyakov@gmail.com>
-
-pkgname=python-allure-commons
-_pkgname=allure-python-commons
-pkgver=2.5.3
+_base=allure
+pkgname=python-${_base}-commons
+pkgver=2.9.45
pkgrel=1
-pkgdesc='Commons of Allure python adaptors for python-based test frameworks'
+pkgdesc="Common module for integrate allure with python-based frameworks"
arch=('any')
-url="https://github.com/allure-framework/allure-python/tree/master/$_pkgname"
-depends=('python' 'python-pluggy>=0.4.0' 'python-six>=1.9.0' 'python-attrs>=16.0.0')
-source=("git+https://github.com/allure-framework/allure-python.git#tag=$pkgver")
-md5sums=('SKIP')
+url="https://github.com/${_base}-framework/${_base}-python"
+depends=(python-pluggy python-six python-attrs)
+makedepends=(python-setuptools-scm git)
+source=("git+${url}.git#tag=${pkgver}")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${_base}-python/${_base}-python-commons"
+ python setup.py build
+}
package() {
- cd "$srcdir/allure-python/$_pkgname"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ cd "${_base}-python/${_base}-python-commons"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}