summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-05-16 21:44:53 +0200
committerNarrat2023-05-16 21:44:53 +0200
commit52467b317921e209a66d8dd11252b33de485da01 (patch)
treef254d9e63cc3566e2f6b446a384b685c95a72b6a
parentf31614f345107e9431d2fd8e35ef5b743f3d1109 (diff)
downloadaur-52467b317921e209a66d8dd11252b33de485da01.tar.gz
altair: add uptream patch for misplaced files
-rw-r--r--.SRCINFO4
-rw-r--r--0001_pyproject.patch24
-rw-r--r--PKGBUILD16
3 files changed, 37 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa1f691c1b92..483fb43e29db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-altair
pkgdesc = Declarative statistical visualization library for Python
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://altair-viz.github.io/
arch = any
license = BSD3
@@ -16,6 +16,8 @@ pkgbase = python-altair
depends = python-toolz
optdepends = python-selenium: png and svg export support
source = altair-5.0.0.tar.gz::https://files.pythonhosted.org/packages/source/a/altair/altair-5.0.0.tar.gz
+ source = 0001_pyproject.patch
sha256sums = 394c3d8be96f9cc90e15a0eee3634cc5b6f19e470fd2045759892623bd9a3fb2
+ sha256sums = 9c67444c235e8f0b1a3aaabfa0787afda9f2b0470a361c112efc202c8432831b
pkgname = python-altair
diff --git a/0001_pyproject.patch b/0001_pyproject.patch
new file mode 100644
index 000000000000..94b75d122007
--- /dev/null
+++ b/0001_pyproject.patch
@@ -0,0 +1,24 @@
+commit 62ca5e37776f5cecb27e83c1fbd5d685a173095d
+Author: Jan Tilly <jan.tilly@quantco.com>
+Date: Sun May 14 15:37:18 2023 +0200
+
+ Remove extra files in site-packages from wheel (#3057)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 18068338..727690b2 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -93,12 +93,7 @@ path = "altair/__init__.py"
+ allow-direct-references = true
+
+ [tool.hatch.build]
+-include = [
+- "/altair",
+- "README.md",
+- "LICENSE",
+- "pyproject.toml"
+-]
++include = ["/altair"]
+
+ [tool.hatch.envs.default]
+ features = ["dev"]
diff --git a/PKGBUILD b/PKGBUILD
index 3424958b56c9..c55505339ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=python-altair
_pyname=altair
pkgname=('python-altair')
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Declarative statistical visualization library for Python"
arch=('any')
url="https://altair-viz.github.io/"
@@ -13,10 +13,17 @@ license=('BSD3')
depends=(python-jinja python-jsonschema python-numpy python-pandas python-toolz)
makedepends=(python-build python-installer python-wheel python-hatchling)
optdepends=('python-selenium: png and svg export support')
-source=("${_pyname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz")
-sha256sums=('394c3d8be96f9cc90e15a0eee3634cc5b6f19e470fd2045759892623bd9a3fb2')
+source=("${_pyname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz"
+ 0001_pyproject.patch)
+sha256sums=('394c3d8be96f9cc90e15a0eee3634cc5b6f19e470fd2045759892623bd9a3fb2'
+ '9c67444c235e8f0b1a3aaabfa0787afda9f2b0470a361c112efc202c8432831b')
+prepare() {
+ cd ${_pyname}-${pkgver}
+ patch -Np1 -i "${srcdir}"/0001_pyproject.patch
+}
+
build () {
cd "${_pyname}-${pkgver}"
python -m build --wheel --no-isolation
@@ -27,9 +34,6 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
-
- # Remove unnecessary and wrongly installed files
- rm -v "$pkgdir"/usr/lib/python3.11/site-packages/{README.md,LICENSE,pyproject.toml}
}
# vim:set et sw=2 ts=2 tw=79: