summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-10-26 11:14:41 +0200
committerPhilipp A2022-10-26 11:14:41 +0200
commit2fb042211c78f8b138566e895bbb1e39d3937f4b (patch)
treee0b39f4014d02713fe33a1f0819b8a9fc7ed7bee
parent2442c01f83e3eab2181cc9a391c48ee93953b230 (diff)
downloadaur-2fb042211c78f8b138566e895bbb1e39d3937f4b.tar.gz
v0.17.3
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98c474b964db..490d42e51445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = python-altgraph
pkgdesc = A graph (network) package for constructing graphs, BFS and DFS traversals, topological sort, shortest paths, etc. with graphviz output.
- pkgver = 0.17.2
+ pkgver = 0.17.3
pkgrel = 1
url = https://pypi.python.org/pypi/altgraph
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/a/altgraph/altgraph-0.17.2.tar.gz
- sha256sums = ebf2269361b47d97b3b88e696439f6e4cbc607c17c51feb1754f90fb79839158
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/a/altgraph/altgraph-0.17.3.tar.gz
+ sha256sums = ad33358114df7c9416cdb8fa1eaa5852166c505118717021c6a8c7c7abbd03dd
pkgname = python-altgraph
diff --git a/.gitignore b/.gitignore
index 2628841d3873..c27506f4c4e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/pkg/
/src/
/*.tar.gz
-/*.pkg.tar.xz
+/*.pkg.*
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index 6085a7e25a34..a31c083a9ff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
_name=altgraph
-pkgname=python-altgraph
-pkgver=0.17.2
+pkgname=python-$_name
+pkgver=0.17.3
pkgrel=1
pkgdesc='A graph (network) package for constructing graphs, BFS and DFS traversals, topological sort, shortest paths, etc. with graphviz output.'
arch=(any)
url="https://pypi.python.org/pypi/$_name"
license=(MIT)
-depends=(python)
-makedepends=(python-setuptools)
+depends=(python python-setuptools) # setuptools for pkg_resources
+makedepends=(python-setuptools python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('ebf2269361b47d97b3b88e696439f6e4cbc607c17c51feb1754f90fb79839158')
+sha256sums=('ad33358114df7c9416cdb8fa1eaa5852166c505118717021c6a8c7c7abbd03dd')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/python-altgraph/LICENSE"
}