summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2020-08-20 13:30:27 +0200
committerfordprefect2020-08-20 13:30:27 +0200
commit14fa544b5e3bd36d1082a945a94287fff35580fa (patch)
tree3055d1c44529c80e1e3e3be8878a0472ccb716f1
parent3092a115d89e39993821dbb5096f07e99d6720dd (diff)
downloadaur-14fa544b5e3bd36d1082a945a94287fff35580fa.tar.gz
drep python2 version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeb8f298c9d0..fb2343d2f591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = python-amoeba
license = GPL2
makedepends = python
makedepends = python2
+ depends = python
source = http://stitchpanorama.sourceforge.net/Python/amoeba.py
source = deepcopy.patch
source = setup.py
@@ -15,8 +16,4 @@ pkgbase = python-amoeba
md5sums = c68322a7608767cc03012e62b3baa546
pkgname = python-amoeba
- depends = python
-
-pkgname = python2-amoeba
- depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index a1b03bd43502..9a5b96826187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
-# Maintainer: fordprefect <fordprefect@dukun.de>
-pkgbase=python-amoeba
-pkgname=("python-amoeba" "python2-amoeba")
+pkgname=python-amoeba
pkgver=1.2
pkgrel=2
pkgdesc="Amoeba fit routine based on the method of Nelder and Meads"
url="https://stitchpanorama.sourceforge.net/Python/amoeba.py"
arch=('any')
license=('GPL2')
+depends=('python')
makedepends=("python" "python2")
source=("http://stitchpanorama.sourceforge.net/Python/amoeba.py"
"deepcopy.patch"
@@ -21,13 +20,6 @@ prepare() {
patch amoeba.py deepcopy.patch
}
-package_python2-amoeba() {
- depends=('python2')
- python2 setup.py install --root="${pkgdir}/" --optimize=1
-
-}
-
-package_python-amoeba() {
- depends=('python')
+package() {
python setup.py install --root="${pkgdir}/" --optimize=1
}