summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-06-15 16:08:43 +0200
committerGeorg Schlisio2015-06-15 16:08:43 +0200
commit30a227a2e81c70b828f7241d52e734cf1771fdd9 (patch)
tree2803f8afbb6fa375c802a31142e61a8753e77d20
downloadaur-30a227a2e81c70b828f7241d52e734cf1771fdd9.tar.gz
version 1.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--setup.py7
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e98f955687c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-amoeba
+ pkgdesc = Amoeba fit routine based on the method of Nelder and Meads
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://stitchpanorama.sourceforge.net/Python/amoeba.py
+ arch = any
+ license = GPL2
+ makedepends = python
+ makedepends = python2
+ source = http://stitchpanorama.sourceforge.net/Python/amoeba.py
+ source = setup.py
+ md5sums = 7e6a9ad95d8639ec3d1da7c6db0928fb
+ md5sums = c68322a7608767cc03012e62b3baa546
+
+pkgname = python-amoeba
+ depends = python
+
+pkgname = python2-amoeba
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..753fd8647a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgbase=python-amoeba
+pkgname=("python-amoeba" "python2-amoeba")
+pkgver=1.2
+pkgrel=1
+pkgdesc="Amoeba fit routine based on the method of Nelder and Meads"
+url="http://stitchpanorama.sourceforge.net/Python/amoeba.py"
+arch=('any')
+license=('GPL2')
+makedepends=("python" "python2")
+source=("http://stitchpanorama.sourceforge.net/Python/amoeba.py"
+ "setup.py")
+md5sums=('7e6a9ad95d8639ec3d1da7c6db0928fb'
+ 'c68322a7608767cc03012e62b3baa546')
+
+package_python2-amoeba() {
+ depends=('python2')
+
+ ## determine python minor version
+ #ver=$(python2 --version 2>&1 | cut -d" " -f2 | cut -d"." -f2)
+ #mkdir -p "${pkgdir}/usr/lib/python2.${ver}/site-packages/amoeba"
+ #touch "${pkgdir}/usr/lib/python2.${ver}/site-packages/amoeba/__init__.py"
+ #install -m644 amoeba.py "${pkgdir}/usr/lib/python2.${ver}/site-packages/amoeba"
+
+ ls
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+}
+
+package_python-amoeba() {
+ depends=('python')
+ ls
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ ## determine python minor version
+ #ver=$(python --version 2>&1 | cut -d" " -f2 | cut -d"." -f2)
+ #mkdir -p "${pkgdir}/usr/lib/python3.${ver}/site-packages/amoeba"
+ #touch "${pkgdir}/usr/lib/python3.${ver}/site-packages/amoeba/__init__.py"
+ #install -m644 amoeba.py "${pkgdir}/usr/lib/python3.${ver}/site-packages/amoeba"
+}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..bbc2db8c8d7d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,7 @@
+from distutils.core import setup
+setup(name='amoeba',
+ version='1.2',
+ py_modules=['amoeba'],
+ description="",
+ author="Thomas R. Metcalf",
+ )