summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-05-16 19:01:00 +0200
committer0x9fff002020-05-16 19:01:00 +0200
commit6ac4bf521faf35100870beac8b4f34edf466c383 (patch)
treeb2c796d07dc6690f8c31d1d2811eb9cfe771a47e
downloadaur-6ac4bf521faf35100870beac8b4f34edf466c383.tar.gz
1.0.3-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--PKGBUILD33
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fee104783397
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-amulet-nbt
+ pkgdesc = A Python and Cython library for reading and writing binary NBT and stringified NBT
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/Amulet-Team/Amulet-NBT
+ arch = x86_64
+ license = unknown
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ source = python-amulet-nbt-1.0.3.tar.gz::https://github.com/Amulet-Team/Amulet-NBT/archive/1.0.3.tar.gz
+ sha256sums = 9d0acb768a36dec288c67ae0591d895957b21c2f76f4bbd715c782a47a8ec2ad
+
+pkgname = python-amulet-nbt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3256e6ceecc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+
+_name=Amulet-NBT
+pkgname=python-${_name,,}
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='A Python and Cython library for reading and writing binary NBT and stringified NBT'
+arch=('x86_64')
+url="https://github.com/Amulet-Team/$_name"
+license=('unknown')
+depends=('python' 'python-numpy')
+makedepends=('cython' 'python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('9d0acb768a36dec288c67ae0591d895957b21c2f76f4bbd715c782a47a8ec2ad')
+
+prepare() {
+ cd "$_name-$pkgver"
+
+ # remove this in next version
+ sed -i 's/==/>=/' requirements.txt
+}
+
+build() {
+ cd "$_name-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}