summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwjhandley2023-06-18 14:08:31 +0000
committerwjhandley2023-06-18 14:08:31 +0000
commit118831808a54a83582a385d9ae6fb03a695355d2 (patch)
tree40006bf783fe71ae383a5d9328f56cbf3a9ae4fa
parent35576fce0e201ae525712f983df0b17efb4e4f86 (diff)
downloadaur-118831808a54a83582a385d9ae6fb03a695355d2.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 166a84df3e61..7209f1a28d93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-anesthetic
pkgdesc = nested sampling post-processing
- pkgver = 2.0.0b37
+ pkgver = 2.0.0b39
pkgrel = 2
url = https://github.com/handley-lab/anesthetic
arch = any
@@ -11,8 +11,9 @@ pkgbase = python-anesthetic
depends = python-matplotlib
depends = python-scipy
depends = python-pandas
+ provides = anesthetic
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/a/anesthetic/anesthetic-2.0.0b37.tar.gz
- sha256sums = a0046181ae2eb1be63f4a1b99ca911f47cb5a0c86cabd567ce65519a6cd47507
+ source = https://files.pythonhosted.org/packages/source/a/anesthetic/anesthetic-2.0.0b39.tar.gz
+ sha256sums = 9c6e585f9432b9640d4dbbbece85079a750659c1982ed0d2baa6a9e63a7bd737
pkgname = python-anesthetic
diff --git a/PKGBUILD b/PKGBUILD
index e08e51f8c8d5..298674073bdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=python-anesthetic
_name=${pkgname#python-}
-pkgver=2.0.0b37
+pkgver=2.0.0b39
pkgrel=2
pkgdesc="nested sampling post-processing"
arch=(any)
@@ -10,14 +10,14 @@ license=(MIT)
groups=()
depends=(python-numpy python-matplotlib python-scipy python-pandas)
makedepends=(python-build python-installer)
-provides=()
+provides=(anesthetic)
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
install=
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('a0046181ae2eb1be63f4a1b99ca911f47cb5a0c86cabd567ce65519a6cd47507')
+sha256sums=('9c6e585f9432b9640d4dbbbece85079a750659c1982ed0d2baa6a9e63a7bd737')
build() {
cd "$srcdir/$_name-$pkgver"