summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:41:21 +0100
committerWill Handley2022-06-07 21:41:21 +0100
commit2546b015e10910e6c80b2fa3c2598ceaa5122dc3 (patch)
treef351d8244738743eb7325e4010bea4c10e5c3aee
parentfd8024ac06ba42f67d25295a0d0ef901b6eb64f6 (diff)
downloadaur-2546b015e10910e6c80b2fa3c2598ceaa5122dc3.tar.gz
Added a stable version
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f69746823c..640271511132 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-anesthetic
pkgdesc = nested sampling visualisation
- pkgver = 1.3.6
- pkgrel = 4
+ pkgver = 2.0.0b11
+ pkgrel = 1
url = https://github.com/williamjameshandley/anesthetic
arch = any
license = MIT
@@ -12,7 +12,7 @@ pkgbase = python-anesthetic
depends = python-scipy
depends = python-pandas
options = !emptydirs
- source = https://github.com/williamjameshandley/anesthetic/archive/1.3.6.tar.gz
- sha256sums = 9c4a97905fb94a5d832f002140b356f3a7bff9cfb7d662dbccb9f76b60963ee3
+ source = https://files.pythonhosted.org/packages/source/a/anesthetic/anesthetic-2.0.0b11.tar.gz
+ sha256sums = 45bfea3a2d5debf2f18080c90c2044ef263091ced6679cfab0c55200aede6314
pkgname = python-anesthetic
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index a7017577a37d..9b9fa2e795b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=anesthetic
-pkgname=python-$_modulename
-pkgver=1.3.6
-pkgrel=4
+pkgname=python-anesthetic
+_name=${pkgname#python-}
+pkgver=2.0.0b11
+pkgrel=1
pkgdesc="nested sampling visualisation"
arch=(any)
url="https://github.com/williamjameshandley/anesthetic"
@@ -16,13 +16,15 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('9c4a97905fb94a5d832f002140b356f3a7bff9cfb7d662dbccb9f76b60963ee3')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(45bfea3a2d5debf2f18080c90c2044ef263091ced6679cfab0c55200aede6314)
build() {
- cd "$srcdir/$_modulename-$pkgver/"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
+
package() {
- cd "$srcdir/$_modulename-$pkgver/"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+