summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-05-14 19:44:25 +0100
committerWill Handley2019-05-14 19:44:25 +0100
commitbd0cc6ad387e925e45c237d127311627907625b6 (patch)
tree5152510505264fcd8b11c2d59cf8fbd31be991c5
downloadaur-bd0cc6ad387e925e45c237d127311627907625b6.tar.gz
version 1.0.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb2e54e5db45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue May 14 18:44:15 UTC 2019
+pkgbase = python-anesthetic
+ pkgdesc = nested sampling visualisation
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/williamjameshandley/anesthetic
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-fastkde
+ options = !emptydirs
+ source = https://github.com/williamjameshandley/anesthetic/archive/1.0.2.tar.gz
+ sha256sums = cd2fbcd2bcf31d51da2432f2ebabbbf2771772bf4726cfa060d057b8187e86e2
+
+pkgname = python-anesthetic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d20b1df83388
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=anesthetic
+pkgname=python-$_modulename
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="nested sampling visualisation"
+arch=(any)
+url="https://github.com/williamjameshandley/anesthetic"
+license=('MIT')
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-scipy' 'python-pandas' 'python-fastkde')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('cd2fbcd2bcf31d51da2432f2ebabbbf2771772bf4726cfa060d057b8187e86e2')
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}