summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-08-11 14:08:57 +0200
committerPhilipp A2017-08-11 14:08:57 +0200
commit2e6685f3e553239a9f57f82a9ea1e927ea8cd54c (patch)
treef078e70e1a89b24ff79d0b5d3da0982ca1641c08
parente96626d03f6b302adf7413f9599dcfa9863ab10c (diff)
downloadaur-2e6685f3e553239a9f57f82a9ea1e927ea8cd54c.tar.gz
added optdepends
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5888573225f4..92f962fa8d27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri May 19 16:22:33 UTC 2017
pkgbase = python-anglerfish
pkgdesc = Helper library for Python 3 apps
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/anglerfish
arch = any
license = GPLv3
depends = python
+ optdepends = cpulimit: Control CPU usage on your App.
+ optdepends = libwebp: WebP support for images on Base64 Data-URI.
+ optdepends = python-dbus: Freedesktop.org native notifications and hardware status support.
+ optdepends = xsel: Clipboard selection support.
+ optdepends = xclip: Clipboard copy and paste support.
+ optdepends = xorg-xset: X11 display support to turn off display.
source = https://files.pythonhosted.org/packages/source/a/anglerfish/anglerfish-2.5.0.zip
md5sums = 8f55508b1efc21603edf2fe49fa06595
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..125d0b52ffcd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.zip
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 9d21d5cdeb49..e554c40b16da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,20 @@
_name=anglerfish
pkgname=python-$_name
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Helper library for Python 3 apps'
arch=('any')
url="http://pypi.python.org/pypi/$_name"
license=('GPLv3')
depends=('python')
+optdepends=(
+ 'cpulimit: Control CPU usage on your App.'
+ 'libwebp: WebP support for images on Base64 Data-URI.'
+ 'python-dbus: Freedesktop.org native notifications and hardware status support.'
+ 'xsel: Clipboard selection support.'
+ 'xclip: Clipboard copy and paste support.'
+ 'xorg-xset: X11 display support to turn off display.'
+)
_wheel="$_name-$pkgver-py2.py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.zip")
md5sums=('8f55508b1efc21603edf2fe49fa06595')