summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-11-15 10:12:28 +0100
committerPhilipp A2017-11-15 10:12:28 +0100
commit350cefc4263bc1a7d907a3c7497c2f6076209679 (patch)
tree5af08697184f684d855ef08d5b62c0f8a8e648a4
downloadaur-350cefc4263bc1a7d907a3c7497c2f6076209679.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50d59c16c4b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-anndata
+ pkgdesc = A data structure for rectangular numeric data and sample/variable annotations.
+ pkgver = 0.3.0.1
+ pkgrel = 1
+ url = https://github.com/theislab/anndata
+ arch = any
+ license = GPL3
+ depends = python-pandas
+ depends = python-scipy
+ source = anndata-0.3.0.1.tar.gz::https://github.com/theislab/anndata/archive/0.3.0.1.tar.gz
+ md5sums = 17f4ff5991142aab4591417b4185989a
+
+pkgname = python-anndata
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..24f2ec57e666
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93377acd3a5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+
+_name=anndata
+pkgname=python-$_name
+pkgver=0.3.0.1
+pkgrel=1
+pkgdesc='A data structure for rectangular numeric data and sample/variable annotations.'
+arch=(any)
+url="https://github.com/theislab/$_name"
+license=(GPL3)
+depends=(python-pandas python-scipy)
+source=("$_name-$pkgver.tar.gz::https://github.com/theislab/anndata/archive/0.3.0.1.tar.gz")
+md5sums=('17f4ff5991142aab4591417b4185989a')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}